<!doctype html>
<html lang="en">
<head>	
	        <!-- <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" /> -->
		<meta http-equiv='Content-Type' content='text/html; charset=UTF-8' /> 
		<title>Gamasutra: Patrick Lipo's Blog - Brass Tactics: Evolving classic RTS interactions for VR - Part 1</title>
	<meta name="pagecaching" content="441" />
	<meta name="serveraddress" content="10.40.36.65" />
			<meta name="keywords" content="game development, game developer, game programming, game programmer, videogame, artificial intelligence, 3D animation, game design, 3D modeling, game business, game jobs, game directory, game development software, game technology, 3D technology, game producer, game audio, game animation, virtual reality, digital entertainment, PC game, Xbox game, game news, new game, arcade development, Nintendo development, Playstation development, Playstation 2, PS2, Dreamcast development, Game Developer magazine, Computer Game Developers Conference, Game Developers Conference, Independent Game Developers Conference, CMP Game Media Group, game industry research, online game development, digital assets, free textures, free 3D models, free shaders, Gamasutra Exchange, 3D Studio Max textures" /><meta name="description" content="The goal of Brass Tactics started simply: Make an RTS that embraced the medium of VR... Luckily, we were blessed with a lot of freedom to explore what" />
		<!--[if lt IE 9]>
		<script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script>
	<![endif]-->
	<style>
		
			.cke_source{
				white-space:normal !important;
			}
			.hide_phone > iframe {
				width: 100%;
			}
			@media only screen and (max-width:479px){
				.hide_phone > iframe {
					height: auto;
				}
				.embeddedContent iframe, .page_data_1 iframe {
					width: 100%;
				}
			}
			.properties ul li {
				padding: 5px 28px !important;
			}
			.formElement label.questionLabel p.description {
				font-weight: normal;
				padding: 0 !important;
			}
			div#rightlinks ul {
				padding: 0 15px !important;
			}
			.article img {
				max-width: 100% !important;
			}
			@media screen and (max-width: 425px) {
				blockquote{
					float:none !important;
					clear:both;
				}
			}
		

	</style>
	<!-- CSS -->
        
        
<meta property="fb:app_id" content="1424004174373289"/>		
        			 <meta property="og:type" content="article"/>
			 <meta property="og:url"  content="http://www.gamasutra.com/blogs/PatrickLipo/20180806/321208/Brass_Tactics_Evolving_classic_RTS_interactions_for_VR__Part_1.php" />
			 <meta property="og:title" content="Brass Tactics: Evolving classic RTS interactions for VR - Part 1" />
                   	 	
                                <meta name="og:image" content="http://www.gamasutra.com/blogs/edit/img/portrait/2207/portrait.jpg" />
                         			 <meta property="og:description" content="The goal of Brass Tactics started simply: Make an RTS that embraced the medium of VR... Luckily, we were blessed with a lot of freedom to explore what that meant. As we iterated towards the final product, we made a lot of interesting stops along the way. " />
				
		<meta name="twitter:card" content="summary" />
		<meta name="twitter:site" content="@gamasutra" />
		<meta name="twitter:creator" content="@gamasutra" />
					<meta name="twitter:title" content="Brass Tactics: Evolving classic RTS interactions for VR - Part 1" />
			<meta name="twitter:description" content="The goal of Brass Tactics started simply: Make an RTS that embraced the medium of VR... Luckily, we were blessed with a lot of freedom to explore what that meant. As we iterated towards the final product, we made a lot of interesting stops along the way. " />
			<meta name="twitter:creator" content="@gamasutra" />
			<meta name="twitter:url" content="http://www.gamasutra.com/blogs/PatrickLipo/20180806/321208/Brass_Tactics_Evolving_classic_RTS_interactions_for_VR__Part_1.php" />
			<meta name="twitter:image" content="http://www.gamasutra.com/blogs/edit/img/portrait/2207/portrait.jpg" />
		
        
                	<link rel="canonical" href="http://www.gamasutra.com/blogs/PatrickLipo/20180806/321208/Brass_Tactics_Evolving_classic_RTS_interactions_for_VR__Part_1.php" />
                <link rel="alternate" type="application/rss+xml" title="Gamasutra Article Feed" href="http://feeds.feedburner.com/GamasutraFeatureArticles/" />
        <link rel="alternate" type="application/rss+xml" title="Gamasutra News Feed" href="http://feeds.feedburner.com/GamasutraNews/" />
        <link rel="alternate" type="application/rss+xml" title="Gamasutra Columns Feed" href="http://feeds.feedburner.com/GamasutraColumns/" />
        <link rel="alternate" type="application/rss+xml" title="Gamasutra Jobs Feed" href="http://feeds.feedburner.com/GamasutraJobs/" />
        <!-- link href="https://twimgs.com/gamasutra/css/minified.css" rel="stylesheet" type="text/css" / -->
        <link href="https://twimgs.com/nojitter/gama/css/gama_unminified.css?v1" rel="stylesheet" type="text/css" />
		<style>
			
				#div-gpt-ad-Ltile1 {
					margin-top: 10px;
				}
			
		</style>
        
        <meta name="node" content="65"/>
        <meta name="pagecaching" content="469"/>
                <script type="text/javascript" src="https://epromos.ubmcanon.com/at.js?ormzkk"></script>
        <script type="text/javascript" src="https://twimgs.com/nojitter/gama/js/redesign_comments.js"></script>
		<script src="//code.jquery.com/jquery-1.8.2.min.js"></script>
		<script type="text/javascript"> 
        
		function checkMail(obj){
	 
		   var think_opt_out = document.getElementById('Think_Opt_Out');
	 
		   if (document.getElementById('Think_Opt_Out').checked) {
	 
				 document.getElementById('Think_Opt_In').value = 0;
		   } else {
	 
				 document.getElementById('Think_Opt_In').value = 1;
		   }
		   var firstname = document.getElementById('firstname').value;
		   if (firstname == ""){
				 alert('Please provide your first name');
				 return false;
		   }
	 
		   if (document.getElementById('lastname').value == ''){
				 alert("Please provide your lastt name");
				 return false;
		   }
	 
	 
		   var x = document.getElementById('EmailAddr').value;
	 
		   var filter  = /^([a-zA-Z0-9_\.\-])+\@(([a-zA-Z0-9\-])+\.)+([a-zA-Z0-9]{2,4})+$/;
		   if (filter.test(x)) { return true; }
		   else  { alert('Invalid Email Address detected. Please correct.'); return false; }
	 
	 
		}
		 
		</script>
        <script type="text/javascript" src="https://twimgs.com/gamasutra/js/md5.js"></script>

        

        <script type="text/javascript">
        var adrand = parseInt(Math.random()*1000000000, 10);
        var adkeys = "key1+key2+key3+key4";
        </script>

        	<!-- Mobile Specific Metas -->
	<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1" /> 
	
	<script type="text/javascript">
            
		var browser			= navigator.userAgent;
		var browserRegex	= /(Android|BlackBerry|IEMobile|Nokia|iP(ad|hone|od)|Opera M(obi|ini))/;
		var isMobile		= false;
		if(browser.match(browserRegex)) {
			isMobile			= true;
			
		}
        
	</script>
        <!-- Start Visual Website Optimizer Asynchronous Code -->
        <script type='text/javascript'>
        
        var _vwo_code=(function(){
        var account_id=32069,
        settings_tolerance=2000,
        library_tolerance=2500,
        use_existing_jquery=false,
        // DO NOT EDIT BELOW THIS LINE
        f=false,d=document;return{use_existing_jquery:function(){return use_existing_jquery;},library_tolerance:function(){return library_tolerance;},finish:function(){if(!f){f=true;var a=d.getElementById('_vis_opt_path_hides');if(a)a.parentNode.removeChild(a);}},finished:function(){return f;},load:function(a){var b=d.createElement('script');b.src=a;b.type='text/javascript';b.innerText;b.onerror=function(){_vwo_code.finish();};d.getElementsByTagName('head')[0].appendChild(b);},init:function(){settings_timer=setTimeout('_vwo_code.finish()',settings_tolerance);this.load('//dev.visualwebsiteoptimizer.com/j.php?a='+account_id+'&u='+encodeURIComponent(d.URL)+'&r='+Math.random());var a=d.createElement('style'),b='body{opacity:0 !important;filter:alpha(opacity=0) !important;background:none !important;}',h=d.getElementsByTagName('head')[0];a.setAttribute('id','_vis_opt_path_hides');a.setAttribute('type','text/css');if(a.styleSheet)a.styleSheet.cssText=b;else a.appendChild(d.createTextNode(b));h.appendChild(a);return settings_timer;}};}());_vwo_settings_timer=_vwo_code.init();
        
        </script>
        <!-- End Visual Website Optimizer Asynchronous Code -->
       
        
        <!-- Start HeatMap.me Code -->
		<script type='text/javascript'>
		(function(h,e,a,t,m,p)
		{ m=e.createElement(a);m.async=!0;m.src=t; p=e.getElementsByTagName(a)[0];p.parentNode.insertBefore(m,p); }
		)(window,document,'script','https://u.heatmap.it/log.js');
		</script>
		<!-- End HeatMap.me Code -->
        
        
        <!-- Start: GPT Sync -->
        <script type='text/javascript'>
         
         var gptadslots=[];
         (function(){
          var useSSL = 'https:' == document.location.protocol;
          var src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
          document.write('<scr' + 'ipt src="' + src + '"></scr' + 'ipt>');
         })();
         
        </script>

        <script type="text/javascript">
              
                      googletag.pubads().setTargeting('kw',['design','vr']);
                                            googletag.pubads().setTargeting('aid',['321208']);
          		
				if (document.documentElement.clientWidth > 767)
				{
				//Adslot 19 declaration
		
					gptadslots[19]=googletag.defineSlot('/2441/Gamasutra',[[2,2]],'div-gpt-ad-welcome').setTargeting('pos',['welcome']).addService(googletag.pubads());
		
				}
				else
				{
				//Adslot 20 declaration
		
					gptadslots[20]=googletag.defineSlot('/2441/Gamasutra',[[7,7]],'div-gpt-ad-mi').setTargeting('pos',['mi']).addService(googletag.pubads());
		
				}
				  
		
				if (document.documentElement.clientWidth > 767){//Adslot 3 declaration
		
					gptadslots[1]= googletag.defineSlot('/2441/Gamasutra', [[1,2]],'div-gpt-ad-skin').setTargeting('pos',['skin']).addService(googletag.pubads());

					gptadslots[2]= googletag.defineSlot('/2441/Gamasutra', [[728,90]],'div-gpt-ad-top').setTargeting('pos',['top']).addService(googletag.pubads());
		
				}else{ 
		
					gptadslots[13]= googletag.defineSlot('/2441/Gamasutra', [[300,50]],'div-gpt-ad-mobile_leaderboard').setTargeting('pos',['mobile_leaderboard']).addService(googletag.pubads());
		

		}
		            
          //Adslot 1 declaration
       

				  //Adslot 2 declaration
		
				if (document.documentElement.clientWidth > 767){//Adslot 3 declaration
		

					 //Adslot 3 declaration
					 gptadslots[3]= googletag.defineSlot('/2441/Gamasutra', [[164,59]],'div-gpt-ad-button1').setTargeting('pos',['button1']).addService(googletag.pubads());

					 //Adslot 4 declaration
					 gptadslots[4]= googletag.defineSlot('/2441/Gamasutra', [[164,59]],'div-gpt-ad-button2').setTargeting('pos',['button2']).addService(googletag.pubads());

					 //Adslot 5 declaration
					 gptadslots[5]= googletag.defineSlot('/2441/Gamasutra', [[164,409]],'div-gpt-ad-callout').setTargeting('pos',['callout']).addService(googletag.pubads());
		

				}
		
						
			//Adslot 6 declaration
			gptadslots[6]= googletag.defineSlot('/2441/Gamasutra', [[300,250]],'div-gpt-ad-rec1').setTargeting('pos',['rec1']).addService(googletag.pubads());
						
		
				if (document.documentElement.clientWidth > 767){//Adslot 3 declaration
		

					 //Adslot 7 declaration
					 gptadslots[7]= googletag.defineSlot('/2441/Gamasutra', [[160,600]],'div-gpt-ad-sky1').setTargeting('pos',['sky1']).addService(googletag.pubads());

					 //Adslot 8 declaration
					 gptadslots[8]= googletag.defineSlot('/2441/Gamasutra', [[160,160]],'div-gpt-ad-Ltile1').setTargeting('pos',['Ltile1']).addService(googletag.pubads());

					 //Adslot 9 declaration
					 gptadslots[9]= googletag.defineSlot('/2441/Gamasutra', [[164,177]],'div-gpt-ad-custom1').setTargeting('pos',['custom1']).addService(googletag.pubads());

					
					 //Adslot 11 declaration
					 gptadslots[11]= googletag.defineSlot('/2441/Gamasutra', [[164,177]],'div-gpt-ad-custom3').setTargeting('pos',['custom3']).addService(googletag.pubads());
					  
          
		
		}
		
		 gptadslots[14]= googletag.defineSlot('/2441/Gamasutra', [[3,3]],'div-gpt-ad-ribbon').setTargeting('pos',['ribbon']).addService(googletag.pubads());
		 		 		 													//Adslot 21 declaration
			gptadslots[21]=googletag.defineSlot('/2441/Gamasutra',[[8,2]],'div-gpt-ad-native').setTargeting('pos',['native']).addService(googletag.pubads());
			//Adslot 22 declaration
			gptadslots[22]=googletag.defineSlot('/2441/Gamasutra',[[8,4]],'div-gpt-ad-insight').setTargeting('pos',['insight']).addService(googletag.pubads());
			//Adslot 23 declaration
			gptadslots[23]=googletag.defineSlot('/2441/Gamasutra',[[4,4]],'div-gpt-ad-video').setTargeting('pos',['video']).addService(googletag.pubads());
		

         googletag.pubads().enableSingleRequest();
         googletag.pubads().enableSyncRendering();
         googletag.enableServices();
        </script>
        <!-- End: GPT -->
	
	<script type="text/javascript">
	
	  var _AdsNativeOpts =
	  {
	
		keywords: ['']
	
	  };
	
	</script>
        
         		<script type="text/javascript">
 		
			var _gaq = _gaq || [];
			_gaq.push(['_setAccount', 'UA-48094207-1']);
			_gaq.push(['_trackPageview']);
			(function()
			{ var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true; ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js'; var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s); }
			)();
		
		</script>
		<link rel="stylesheet" href="https://i.ubm-us.net/oas/nativead/css/game_nativead.css" />
		<script language="JavaScript" src="https://i.ubm-us.net/oas/nativead/js/nativead.js"></script>
		<script language="JavaScript" src="https://i.ubm-us.net/oas/nativead/js/game_nativead.js"></script>
			<!-- Twitter universal website tag code -->
		<script>
		
		!function(e,t,n,s,u,a){e.twq||(s=e.twq=function(){s.exe?s.exe.apply(s,arguments):s.queue.push(arguments);
		},s.version='1.1',s.queue=[],u=t.createElement(n),u.async=!0,u.src='//static.ads-twitter.com/uwt.js',
		a=t.getElementsByTagName(n)[0],a.parentNode.insertBefore(u,a))}(window,document,'script');
		// Insert Twitter Pixel ID and Standard Event data below
		twq('init','nx55r');
		twq('track','PageView');
		
		</script>
		<!-- End Twitter universal website tag code -->
		
		<!-- Facebook Pixel Code -->
		<script>
		
		!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
		n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
		n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
		t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
		document,'script','https://connect.facebook.net/en_US/fbevents.js');
		fbq('init', '832000476880185'); // Insert your pixel ID here.
		fbq('track', 'PageView');
		
		</script>
		<noscript><img height="1" width="1" style="display:none"
		src="https://www.facebook.com/tr?id=832000476880185&ev=PageView&noscript=1"
		/></noscript>
		<!-- DO NOT MODIFY -->
		<!-- End Facebook Pixel Code -->
		
</head>
<body >
	<!-- Beginning Sync AdSlot 19 for Ad unit Gamasutra/ ### size: [[2,2]]  -->
<div id='div-gpt-ad-welcome'>
 <script type='text/javascript'>
  googletag.display('div-gpt-ad-welcome');
 </script>
</div>
<!-- End AdSlot 19 -->
	<!-- Beginning Sync AdSlot 20 for Ad unit Gamasutra/ ### size: [[7,7]]  -->
<div id='div-gpt-ad-mi'>
 <script type='text/javascript'>
  googletag.display('div-gpt-ad-mi');
 </script>
</div>
<!-- End AdSlot 20 -->
    <div class="hide-phone">
                                <!-- Beginning Sync AdSlot 1 for Ad unit Gamasutra/ ### size: [[1,2]]  -->
<div id='div-gpt-ad-skin'>
 <script type='text/javascript'>
  googletag.display('div-gpt-ad-skin');
 </script>
</div>
<!-- End AdSlot 1 -->
            </div>

    <div class="hide-phone">
         <div class="wrapper properties">
            <div class="container">
                    <ul>
                        <li>Our Properties:</li>
                        <li class="activetab"><a href="/" class="active">Gamasutra</a></li>
                        <li><a href="http://www.gamecareerguide.com">GameCareerGuide</a></li>
                        <li><a href="http://www.indiegames.com">IndieGames</a></li>
                        <li><a href="http://www.gdcvault.com">GDC Vault</a></li>
                        <li><a href="http://www.gdconf.com">GDC</a></li>
                        <li><a href="http://www.igf.com">IGF</a></li>
                   </ul>
              </div>
         </div><!--end wrapper-->
    </div>
    
    <br />
     <div class="container bottom3">
     	<div class="span-7">
          	<a href="http://www.gamasutra.com"><img src="https://twimgs.com/gamasutra/images/gamasutra_logo.png" alt="Gamasutra: The Art &amp; Business of Making Games" width="243" height="77" border="0" /></a><img alt="spacer" src="https://twimgs.com/gamasutra/images/spacer.gif" width="27" />
		</div>
          <div class="hide-phone">
              <div class="div span-16 last leaderboard">
                     
                                                                               <!-- Beginning Sync AdSlot 2 for Ad unit Gamasutra/ ### size: [[728,90]]  -->
<div id='div-gpt-ad-top'>
 <script type='text/javascript'>
  googletag.display('div-gpt-ad-top');
 </script>
</div>
<!-- End AdSlot 2 -->
                                           
    
              </div>
          </div>
    </div>
          
<div class="container"> 
		<div class="span-20">
			<div class="show-phone clearfix" style="padding:0px 0 5px 0"><!--sadie change-->
                        <div class="span-5 center ">
								<!-- Beginning Sync AdSlot 2 for Ad unit Gamasutra/ ### size: [[300,50]]  -->
<div id='div-gpt-ad-mobile_leaderboard'>
 <script type='text/javascript'>
  googletag.display('div-gpt-ad-mobile_leaderboard');
 </script>
</div>
<!-- End AdSlot 2 -->

                        </div>
				</div>

                    <div class="show-phone"><!--there is another on the page for the regular size, this is phone only-->
                         <div class="span-5 last nav_search">
                              <div class="content center">
                                   <span class="nav_searchtxt">SEARCH</span>
                                   <form class="left" name="topsearchph" action="/search/" method="GET">
          
                                               <input name="search_text" type="text" size="25" class="search" />	  
                                              <span class="nav_searchbutton"><a href="" onClick="javascript: document.topsearchph.submit(); return false;">GO</a></span>
                                   
                                   </form>
                              </div>
                         </div>
                    </div><!--end show phone-->
                    
                    <div class="show-phone"><!--sadie change-->
                        <div class="span-3">
                                  <div class="login_phone" id="login_phone">
                                       
                                   </div>
                        </div>
                    </div><!--end showphone-->
                    <div class="nav">
                	<div class="span-3 nav_jobs">
                    	<div class="content">
                              <a href="http://jobs.gamasutra.com/">GAME JOBS</a>
                          </div>
                    </div>
                    <div class="span-12 nav_links">
                         <div class="content">
                                   <a href="/updates/">updates</a>
                                   <a href="/blogs/">Blogs</a>
                                   
                                   <a href="/contractors/contractor_display.php">contractors</a>
                                   <a href="/newsletter-signup">newsletter</a>
                                   <a href="https://store.cmpgame.com/storefront.php?loc=&skin=gamasutra_redesign">store</a>
                         </div>
                    </div>
                    <div class="hide-phone">
                        <div class="span-5 last nav_search">
                             <div class="content">
                                  <span class="nav_searchtxt">SEARCH</span>
                                  <form class="left" name="topsearch" action="/search/" method="GET">

                                              <input name="search_text" type="text" size="10" class="search" />	  
                                             <span class="nav_searchbutton"><a href="" onClick="javascript: document.topsearch.submit(); return false;">GO</a></span>

                                    </form>
                             </div>
                        </div>
                    </div>
                    <br class="clear">
               </div><!--end nav-->
               <div class="hide-phone"> 
                    <div class="span-20 last"> 
                       <div class="topicmenu">
                            <ul>
                                <li class="activetab"><a href="http://www.gamasutra.com">ALL</a>
                                </li><li ><a href="/topic/console-pc">CONSOLE/PC</a>
                                </li><li ><a href="/topic/smartphone-tablet">SMARTPHONE/TABLET</a>
                                </li><li ><a href="/topic/indie">INDEPENDENT</a>
                                </li><li ><a href="/topic/vr">VR/AR</a>
                                </li><li ><a href="/topic/social-online">SOCIAL/ONLINE</a>
                                </li></ul>
                                                          <span class="gdmag"><a href="/topic/game-developer"><img src="https://twimgs.com/gamasutra/images/btn_gdmag0.png" width="118px" height="33px"></a></span>
                       </div>
                   </div>
               </div>		
                    <div class="span-20 last content_bg">
                        <div class="hide-phone">
<div class="span-4">
  <div class="content_box_left">
    <div class="leftcol">
        <!--member login-->
                    <table width="166" border="0" cellspacing="0" cellpadding="0">
  <tr>   
    <td id="memberLogin" class="welcome">
    	
    </td>   
  </tr>
</table>                 <!--end memberlogin-->
        
        <!--begin social icons-->
            <!--begin social icons-->
<div  class="bottom2">
    <ul class="leftcol_social">
       <li class="facebook"><a href="http://www.facebook.com/pages/Gamasutra/31610613408" target="_blank">&nbsp;</a></li>
       <li class="twitter"><a href="http://twitter.com/gamasutra" target="_blank">&nbsp;</a></li>
       <li class="feed"><a href="http://www.gamasutra.com/static2/rssfeeds.html">&nbsp;</a></li>
       <li class="newsletter"><a href="/newsletter-signup">&nbsp;</a></li>
    </ul>
</div>
<!--end social icons-->        <!--end social icons-->
        
        <!--begin page numbers-->
                <!--end page numbers-->
        
        <!--begin leftnav-->
                <div class="leftnav_categories bottom2">
   <a href="/category/programming/"><img alt="arrow" src="https://twimgs.com/gamasutra/images/button_programming.gif"  width="24px" height="24px" /></a>
   <div class="leftnav_btn"><a href="/category/programming/">PROGRAMMING</a></div>

   <hr>

   <a href="/category/art/"><img alt="spacer" src="https://twimgs.com/gamasutra/images/button_art.gif" width="24px" height="24px" /></a>
   <div class="leftnav_btn"><a href="/category/art/">ART</a></div>

   <hr>

   <a href="/category/audio/"><img alt="spacer" src="https://twimgs.com/gamasutra/images/button_audio.gif" width="24px" height="24px"  /></a>         
   <div class="leftnav_btn"><a href="/category/audio/">AUDIO</a></div>

   <hr>

   <a href="/category/design/"><img alt="arrow" src="https://twimgs.com/gamasutra/images/button_design.gif" width="24px" height="24px"  /></a>
   <div class="leftnav_btn"><a href="/category/design/">DESIGN</a></div>

   <hr>

   <a href="/category/production/"><img alt="arrow" src="https://twimgs.com/gamasutra/images/button_production.gif" width="24px" height="24px" /></a>
   <div class="leftnav_btn"><a href="/category/production/">PRODUCTION</a></div>

   <hr>
   <a href="/category/business-marketing/"><img alt="arrow" src="https://twimgs.com/gamasutra/images/button_business.gif" width="24px" height="24px"  /></a>
   <div class="leftnav_btn"><a href="/category/business-marketing/">BIZ/MARKETING</a></div>

   <br class="clear">
</div>          <!--end leftnav-->
                  
                    <!-- Beginning Sync AdSlot 3 for Ad unit Gamasutra/ ### size: [[164,59]]  -->
<div id='div-gpt-ad-button1'>
 <script type='text/javascript'>
  googletag.display('div-gpt-ad-button1');
 </script>
</div>
<!-- End AdSlot 3 -->
            <!-- Beginning Sync AdSlot 4 for Ad unit Gamasutra/ ### size: [[164,59]]  -->
<div id='div-gpt-ad-button2'>
 <script type='text/javascript'>
  googletag.display('div-gpt-ad-button2');
 </script>
</div>
<!-- End AdSlot 4 -->
            <!-- Beginning Sync AdSlot 5 for Ad unit Gamasutra/ ### size: [[164,409]]  -->
<div id='div-gpt-ad-callout'>
 <script type='text/javascript'>
  googletag.display('div-gpt-ad-callout');
 </script>
</div>
<!-- End AdSlot 5 -->
            <!-- Beginning Sync AdSlot 9 for Ad unit Gamasutra/ ### size: [[164,177]]  -->
<div id='div-gpt-ad-custom1'>
 <script type='text/javascript'>
  googletag.display('div-gpt-ad-custom1');
 </script>
</div>
<!-- End AdSlot 9 -->
            <!-- Beginning Sync AdSlot 11 for Ad unit Gamasutra/ ### size: [[164,177]]  -->
<div id='div-gpt-ad-custom3'>
 <script type='text/javascript'>
  googletag.display('div-gpt-ad-custom3');
 </script>
</div>
<!-- End AdSlot 11 -->
                
        <!-- begin event tickers -->
			              
        <!-- end event tickers -->
	
         <!--begin jobs-->
            <div class="header"><img alt="arrow" src="https://twimgs.com/gamasutra/images/icon_jobs.png" width="22px" height="20px"/><a href="http://jobs.gamasutra.com/">Latest Jobs</a></div>
<div class="leftnav bottom2">
     <a href="http://jobs.gamasutra.com/"><strong>View All</strong></a> &nbsp;&nbsp;&nbsp;
     <a href="http://feeds.feedburner.com/GamasutraJobs"><strong>RSS</strong></a>
     <hr>
     <strong>August  9, 2018</strong>
     <hr>
     <ul>    
            <li>Wooga GmbH<br />
              <a href="http://jobs.gamasutra.com/job/game-designer-economy-berlin-33223">Game Designer - Economy</a>
        </li>
        <li class="line"></li>
            <li>Deep Silver Volition<br />
              <a href="http://jobs.gamasutra.com/job/temporary-level-designer-champaign-illinois-33222">Temporary Level Designer</a>
        </li>
        <li class="line"></li>
            <li>Deep Silver Volition<br />
              <a href="http://jobs.gamasutra.com/job/senior-level-designer-champaign-illinois-33221">Senior Level Designer</a>
        </li>
        <li class="line"></li>
            <li>Insomniac Games<br />
              <a href="http://jobs.gamasutra.com/job/director-of-design-burbank-california-32971">Director of Design</a>
        </li>
        <li class="line"></li>
            <li>Velan Studios<br />
              <a href="http://jobs.gamasutra.com/job/sr-multiplayer-level-designer-troy-new-york-33220">Sr. Multiplayer Level Designer</a>
        </li>
        <li class="line"></li>
            <li>Sucker Punch Productions<br />
              <a href="http://jobs.gamasutra.com/job/encounter-designer-bellevue-washington-33218">Encounter Designer</a>
        </li>
        <li class="line"></li>
         </ul>    
</div>
         <!--end jobs-->   
           			
         <!--begin blogs-->
            <div class="header"><img alt="arrow" src="https://twimgs.com/gamasutra/images/icon_blogs.png" width="22px" height="20px"/><a href="/blogs/">Latest Blogs</a></div>
<div class="leftnav bottom2">
    <a href="/blogs/"><strong>View All</strong></a> 
    &nbsp;&nbsp;&nbsp; <a href="/blogs/edit/"><strong>Post</strong></a>
    &nbsp;&nbsp;&nbsp; <a href="/blogs/rss/"><strong>RSS</strong></a>
    <hr>
    <strong>August  9, 2018</strong>
    <hr>   
    <ul>
        
        <li>
            <a href="/blogs/KrzysztofSolarski/20180809/323929/ADAPTIVE_GAMEPLAY_AESTHETICS_PART_1_A_Disruptive_Game_Design_Framework.php">ADAPTIVE GAMEPLAY AESTHETICS (PART 1): A Disruptive Game Design Framework</a>
                    </li>
        <li class="line"></li>
        
        <li>
            <a href="/blogs/TommyThompson/20180806/323715/Cyber_Demons__The_AI_of_DOOM_2016.php">Cyber Demons | The AI of DOOM (2016)</a>
             
                [<a title="2 comments" href="/blogs/TommyThompson/20180806/323715/Cyber_Demons__The_AI_of_DOOM_2016.php#comments">2</a>]
                    </li>
        <li class="line"></li>
        
        <li>
            <a href="/blogs/SimonCarless/20180806/323739/Video_Game_Deep_Cuts_Its_VGDC_Issue_100.php">Video Game Deep Cuts: It's VGDC Issue #100!</a>
                    </li>
        <li class="line"></li>
        
        <li>
            <a href="/blogs/HannahFlynn/20180802/323531/How_a_twitter_campaign_brought_in_95_new_game_reviews.php">How a twitter campaign brought in 95 new game reviews</a>
                    </li>
        <li class="line"></li>
        
        <li>
            <a href="/blogs/NickYee/20180802/323466/What_Men_and_Women_Consider_Hardcore_Gaming_Are_Not_The_Same.php">What Men and Women Consider Hardcore Gaming Are Not The Same</a>
             
                [<a title="1 comments" href="/blogs/NickYee/20180802/323466/What_Men_and_Women_Consider_Hardcore_Gaming_Are_Not_The_Same.php#comments">1</a>]
                    </li>
        <li class="line"></li>
       
    </ul>
</div>
         <!--end blogs-->
         
         <!--begin press releases-->
            <div class="header"><img alt="arrow" src="https://twimgs.com/gamasutra/images/icon_blogs.png" width="22px" height="20px"/>Press Releases</div>
<div class="leftnav bottom2">
    <strong>August  9, 2018</strong>
	<hr>
	       <a href="/pressreleases_index.php"><strong>Games Press</strong></a>
   <hr>
   <ul>
          
        <li>
            <a href="http://www.gamasutra.com/view/pressreleases/324163/MindBending_VR_Puzzle_Adventure_A_Fishermans_Tale_Announced.php">Mind-Bending VR Puzzle<br />
Adventure A<br />
Fisherman's...</a>
        </li>
        <li class="line"></li>
          
        <li>
            <a href="http://www.gamasutra.com/view/pressreleases/324154/Indie_Hit_Freedom_Planet_Races_to_a_Nintendo_Switch_Release_on_August_30_in_North_America_and_Europe.php">Indie Hit Freedom Planet<br />
Races to a Nintendo...</a>
        </li>
        <li class="line"></li>
          
        <li>
            <a href="http://www.gamasutra.com/view/pressreleases/324155/Indie_hit_Freedom_Planet_races_to_a_Nintendo_Switch_release_in_North_America_and_Europe_on_30th_August.php">Indie hit Freedom Planet<br />
races to a Nintendo...</a>
        </li>
        <li class="line"></li>
          
        <li>
            <a href="http://www.gamasutra.com/view/pressreleases/324159/Gear_up_Hunters_Monster_Hunter_World_is_Available_now_on_Steam.php">Gear up, Hunters! Monster<br />
Hunter: World is...</a>
        </li>
        <li class="line"></li>
          
        <li>
            <a href="http://www.gamasutra.com/view/pressreleases/324158/Gear_up_Hunters_Monster_Hunter_World_is_Available_now_on_Steam.php">Gear up, Hunters! Monster<br />
Hunter: World is...</a>
        </li>
        <li class="line"></li>
         </ul>
   <a href="/pressreleases_index.php"><strong>View All</strong></a> 
   &nbsp;&nbsp;&nbsp; <a href="/pressreleases/rss/"><strong>RSS</strong></a>
</div>         <!--end press releases-->
                         
         <!--begin calendar-->
            <!--

<div class="header"><img alt="arrow" src="https://twimgs.com/gamasutra/images/icon_calendar.png" width="22px" height="20px"/><a href="http://www.gamasutra.com/calendar/calendar.php">Calendar</a></div>
<div class="leftnav bottom2">
    <a href="http://www.gamasutra.com/calendar/calendar.php"><strong>View All</strong></a> &nbsp;&nbsp;&nbsp; <a href="http://www.gamasutra.com/calendar/calendar_submit.php"><strong>Submit Event</strong></a>
    <hr>
    <ul>
        
    </ul>
</div>

-->         <!--end calendar-->
                         
         <!--begin about-->
            <div class="header"><img alt="arrow" src="https://twimgs.com/gamasutra/images/icon_about.png" width="22px" height="20px"/><a href="/contactus">About</a></div>
<div class="leftnav bottom2">
    <ul>
            <li><strong>Editor-In-Chief: </strong><br /><a href="/cdn-cgi/l/email-protection#80ebe7f2e1e6f4c0e7e1ede1f3f5f4f2e1aee3efed">Kris Graft</a></li>
            <li class="line"></li>
         
       
            <li><strong> Editor: </strong><br /> <a href="/cdn-cgi/l/email-protection#9dfcf1f8e5b3eafceaeff2dde8fff0b3fef2f0">Alex Wawro</a></li>
          <!--  <li class="line"></li>

            <li><strong>Assignment Editor: </strong><br /> <a href="mailto:chris.baker@ubm.com">Chris Baker</a></li> -->
            <li class="line"></li>
            <li><strong>Contributors: </strong><br />
		Chris Kerr<br />
	    	Alissa McAloon<br />
		Emma Kidwell<br />
		Bryant Francis<br />
		Katherine Cross<br />
            <li><strong>Advertising: </strong><br /><a href="/cdn-cgi/l/email-protection#cea2a7acacb7e0a5bcbbbdab8ebbaca3e0ada1a3">Libby Kruse</a></li>
    </ul>
    <hr>
    <div class="center"><a href="/contactus">Contact Gamasutra</a></div>
    <hr>
    <div class="center"><a href="/cdn-cgi/l/email-protection#b0c3c5c0c0dfc2c4f0d7d1ddd1c3c5c4c2d19ed3dfdd">Report a Problem</a></div>
    <hr>
    <div class="center"><a href="/cdn-cgi/l/email-protection#6f010a181c2f080e020e1c1a1b1d0e410c0002">Submit News</a></div>
    <hr>
    <div class="center"><a href="/static2/comment_guidelines.html">Comment Guidelines</a></div>
    <hr>
    <div class="center"><a href="/static2/blogsubmissions.html">Blogging Guidelines</a></div>
	<hr>
    <div class="center"><a href="/static2/howwework.html">How We Work</a></div>
</div>

<div class="bottom2">
    <a href="http://www.ubmgamenetwork.com/online/" target="_blank">
        <img src="https://twimgs.com/gamasutra/images/AdwGama_177x60_button_v1.jpg" alt="Sponsor" border="0" class="whiteTop"  width="177px" height="60px"/>
    </a>
</div>
             <!--end about-->
         
         <!--begin network-->
            <div class="header"><img alt="arrow" src="https://twimgs.com/gamasutra/images/icon_about.png" width="22px" height="20px"/><a href="#">Gama Network</a></div>
<div class="leftnav_network bottom2">
    If you enjoy reading this site, you might also want to check out these UBM Tech sites:
    <hr>
    <a href="http://www.gamecareerguide.com"><!-- img src="http://www.indiegames.com/blog/gcgmini.jpg" align="left" hspace="2"/ --></a> 
    <div class="leftnav_btn"><a href="http://www.gamecareerguide.com">Game Career Guide</a></div>
    <hr>
    <a href="http://www.indiegames.com/blog"><!-- img src="http://www.indiegames.com/blog/indiemini.jpg" align="left" hspace="2"/ --></a>
    <div class="leftnav_btn"><a href="http://www.indiegames.com/blog">Indie Games</a></div>
    <br class="clear">
</div>         <!--end network-->
         
         <!--begin store-->
                     <!--end store-->
         
                
    </div><!--end leftcol-->
  </div>
</div> 
</div>  	<style>.content_box_middle pre {
		overflow-x:auto;
	}
	.item_title{
		    margin-top: 0px !important;
			margin-bottom: 0px !important;
	}
	</style>
<div class="span-16 last">
    <div class="content_box_middle">
        <!-- InstanceBeginEditable name="BodyContent" --> 
        <div class="header_large">
            <span class="left"><img alt="arrow" src="https://twimgs.com/gamasutra/images/icon_blogs.png"/><a href="/blogs/">Blogs</a></span>
        </div>
        <div class="page_item"> 
                        <div class="clear">&nbsp;</div>
            <h1 class="item_title">Brass Tactics: Evolving classic RTS interactions for VR - Part 1</h1>
            <div>
                <span class="newsAuth">by <a href="/blogs/author/PatrickLipo/2207/">Patrick Lipo</a> on 08/06/18 11:42:00 am 
                                        &nbsp; <img valign="bottom" border="0" src="https://twimgs.com/gamasutra/images/featuredIcon_gamaBlog.gif" alt="Featured Blogs" />                                        <br />
                </span>
            </div>
            <div>
                <br>
                                    <span class="comment_text">
                                                    <a href="#comments">Post A Comment</a>
                                            </span>
                    <a name="twitter_share" type="button" href="http://twitter.com?status=RT @gamasutra: Brass Tactics: Evolving classic RTS interactions for VR - Part 1 http://www.gamasutra.com/blogs/PatrickLipo/20180806/321208/" target="_blank"><img src="https://twimgs.com/gamasutra/images/twitter.gif" alt="Share on Twitter" border="0" height="20"/></a>
                    <iframe src="https://www.facebook.com/plugins/share_button.php?href=https://www.gamasutra.com/blogs/PatrickLipo/20180806/321208/&layout=button&size=large&mobile_iframe=true&width=72&height=28&appId" width="72" height="28" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowTransparency="true"></iframe>

                    <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript" src="https://apis.google.com/js/plusone.js"></script>
                    <g:plusone size="medium" count="false"></g:plusone>
					<span id="edit_post_link"></span>&nbsp;&nbsp;
					<a href="/blogs/rss/"><img src="https://twimgs.com/gamasutra/images/icon_rss.gif" width="15" height="15" border="0" alt="RSS" /></a>
                            </div>
            <hr>
            <div class="item_body mobile_image_transform">       
                <strong><i><small>
                    The following blog post, unless otherwise noted, was written by a member of Gamasutra&#146;s community.<br />
					The thoughts and opinions expressed are those of the writer and not Gamasutra or its parent company.                </small></i></strong>
                <hr>
                <div class="clear">&nbsp;</div>
                <p>In the fall of 2015, Hidden Path made a pitch to Oculus for a game with a clear and understandable premise: To create a real-time strategy game with a miniature clockwork aesthetic. It was clear and inspiring... The company had a long history of exploring games in the RTS vein, and were eager to make a full-blown strategy game in VR. We had all seen the introduction to <a href="https://youtu.be/s7L2PVdrb_8">Game of Thrones</a> and found it an excellent visual inspiration. But, what the game truly would be was still a fairly blank slate... &#39;Real-time Strategy&#39; could mean a lot of things after all, and VR had very few precedents in the strategy genre.</p>

<p>In the project&#39;s first months, we were eager to get going, but we only had a team of 1 or 2 at our disposal... We knew we had to get a grasp of the scale, pace and strategic level of gameplay that would be used in Brass Tactics. Luckily, Oculus had generously given us a few months to really investigate and explore what RTS would be like in VR. It was a perfect opportunity... we didn&#39;t have to make any assumptions, and we were encouraged to build a game that felt natural to play in VR that just happened to be a strategy game, rather than take the standard 2D RTS mold and shoehorn it into a set of goggles.</p>

<p><img alt="" src="https://gamasutra.com/db_area/images/Buildings800.jpg" style="height:210px; width:610px" /></p>

<p>We quickly formed some <a href="https://www.patricklipo.com/2008/06/09/pillars-and-razors/">pillars</a> (primary design goals) that helped us prioritize our feature set as we proceeded:&nbsp;</p>

<ul>
	<li><strong>Accessible RTS Gameplay:</strong> Create a game that would be immediately recognizable as classic real-time strategy, even as the trappings of VR transform the experience. Our audience should feel comfortable and not intimidated by the mechanics or interface.</li>
	<li><strong>Innovation in Interaction: </strong>While the gameplay would be familiar, this RTS experience would evolve to take advantage of VR and the <em>Touch</em> controllers, replacing cursors and menus with a tactile experience where players physically manipulated their environment and units to achieve victory.</li>
	<li><strong>A Tangible Play Space: </strong>Brass Tactics would be presented as an elaborate game made possible by wondrous clockwork creations. To keep the player immersed in this environment, we would not move or teleport the player, but rather present functionality via intricate machinery.</li>
</ul>

<p>Knowing that we didn&#39;t want to just assume anything about the world we would interact with, I launched into exploring the type of world the player might interact with.&nbsp; A wide array of&nbsp;possibilities came about...</p>

<p><iframe allow="autoplay; encrypted-media" allowfullscreen="" frameborder="0" height="315" src="https://www.youtube.com/embed/jWQBvDByjHo" width="560"></iframe></p>

<h1>Early Board Prototypes</h1>

<p>Regardless of how our game played, we knew that we wanted to be as immersive as possible, and not have it <em>feel</em> like a fiddly strategy game. We wanted the experience in the game to be as physical and tactile as we could get away with... and to obey physical laws whenever possible during interaction with the environment.</p>

<p>One of our earliest concerns was research that suggested that players may not be comfortable with virtual objects interpenetrating their body when in VR... that people may have instinctual reactions to virtual objects punching through their midsection. This put us into an interesting situation... We knew we wanted to use the Touch controllers and physically interact with things, but wanted to explore ways to avoid moving through the board to do so.</p>

<p><img alt="" src="https://gamasutra.com/db_area/images/Brass%20Layout%20Experiments.jpg" style="height:481px; width:610px" /></p>

<p>That early in the project we found ourselves lacking any kind of engineering team, so I tried a lot of different configurations in simple (i.e. poorly-coded) Unity prototypes to explore this issue... Since we only had DK2 devkits and no Touch controllers, this was done with a mouse cursor simulating how a Touch would manipulate a surface by grabbing it. This included:</p>

<h2><img alt="" src="https://gamasutra.com/db_area/images/Brass%20Bowl.jpg" style="float:left; height:188px; margin-left:6px; margin-right:6px; width:200px" />Terrain Bowl</h2>

<p>Taking height-mapped terrain, but wrapping it around the player, who then plays within it. The idea is that nothing is incredibly far away from the player, and they can get a good view of the situation by simply turning their head. This could have been interesting but it led to a strange disc-shaped world that we quickly discerned would have been hard to understand...&nbsp; It was like being stuck between the inside of a half-globe and a regular terrain valley.&nbsp;&nbsp;</p>

<h2>Barrel Terrain<img alt="" src="https://gamasutra.com/db_area/images/Brass%20Barrel.jpg" style="border-style:solid; border-width:0px; float:right; height:155px; margin-left:6px; margin-right:6px; width:220px" /></h2>

<p>We put the player inside a rotating cylinder, like a fat halo... This put a lot of stuff within reach, and allowed the player to be near things and rotate by dragging the world in front of them. Unfortunately, even with a few spots on the map to focus on, it was incredibly nauseating to be inside of... probably the most unpleasant feelings we experienced in these tests.</p>

<h2>Globe Map</h2>

<p>One way to put forth a world that the player can interact with is to put it all on a globe, and let the player rotate the globe at will. This gave a &#39;god game&#39; feel to interacting, which certainly would have impacted the gameplay. Nonetheless, the globe (like the bowl and barrel) somehow took away some of the tangibility since we would be changing gravity around its surface. However, rotating the globe in front of you would have been a great feel for a non-mechanical game for certain.</p>

<h2>Inverted Globe</h2>

<p>Like the barrel, we once asked &#39;what if the player was on the <em>inside</em> of a globe, with all gameplay happening around them (like a Brass Dyson Sphere?) It certainly would be even more gameplay within relative reach, but it proved even more nauseating than the cylinder before we even got the whole thing running.</p>

<h2>Four-point &#39;Cloverleaf&#39;</h2>

<p>Still wanting to explore ways for the player to belly-up to the gameplay but still not interpenetrate the map, we explored ways to &#39;cut out&#39; portions of the map, so that a large amount of interactive arena surrounded the player on three sides, where the player could also teleport between four different &#39;cutouts&#39; on the map. This would have required teleportation, as well as the possibility that the opponent would also want to occupy the same area (which was actually extremely likely, since they would probably be controlling combat in the same area as you would). It also involved teleportation, which still removed player&#39;s sense of place and (along with rotation during the teleport) created disorientation.</p>

<h2><img alt="" src="https://gamasutra.com/db_area/images/Brass%20Fixed.jpg" style="float:left; height:205px; margin-left:6px; margin-right:6px; width:200px" />Linear Map with &#39;Cutout&#39;</h2>

<p>A variant of the &#39;cloverleaf&#39; method was to put the player in a fixed location, and have them make all the relevant map decisions from that location from their location. There certainly are examples of strategy games where the player simply spawns units and sends them forth (our comparative example was <a href="https://youtu.be/vvK-qSI_5nM">Nexus Wars</a> for Starcraft 2). This sort of play can be compelling but there are a few issues there. First is that since the player isn&#39;t directly controlling the units, it can take a bit of time to understand how the matchups work. More importantly, the player doesn&#39;t get to be near the enemy base when killing it... that felt significant since at a triumphant moment, you&#39;re peering at something going down ten feet away... and feeling left out.</p>

<h2>Turntable</h2>

<p>This was one of our favorites when we were focusing on keeping the player outside of the world geometry. We continued to speculate that a turntable would manage to keep things interesting and yet allow players to get close. One thing that helped this was to start thinking of Brass Tactics as similar to a miniatures game like <a href="https://boardgamegeek.com/boardgame/130552/warhammer-fantasy-battles-8th-edition">Warhammer</a> or games that take place&nbsp;<a href="https://www.google.com/search?q=mordheim+terrain&amp;safe=off&amp;source=lnms&amp;tbm=isch&amp;sa=X&amp;ved=0ahUKEwjris-ayv7ZAhXrgVQKHdmbAP0Q_AUICygC&amp;biw=1920&amp;bih=1069">in</a><a href="https://www.google.com/search?q=mordheim+terrain&amp;safe=off&amp;source=lnms&amp;tbm=isch&amp;sa=X&amp;ved=0ahUKEwjris-ayv7ZAhXrgVQKHdmbAP0Q_AUICygC&amp;biw=1920&amp;bih=1069"> a single city</a>. The urban layout might have theoretically given us a way to compress the space within the turntable and use tiers, roads and obstructions to squeeze the most possible gameplay into a limited space.</p>

<p>You&#39;ll note in the prototypes in the video that in many of these maps had holes punched through them... It was important for us from the very beginning to make sure the player felt &#39;anchored&#39; in the room, and that the table itself was being moved. We thought that if we could see the floor through gaps in the map that the player could avoid some discomfort. It could have added some neat flourish to our &#39;play table&#39; aesthetic, but it was a lot easier to make maps that didn&#39;t have this particular limitation.</p>

<p>We came out of this process with a better understanding of world sizes, object size and scope, and the distance at which you might have been able to interact. Taking some inspiration from tabletop did give us a target for the sort of elegance and intricacy we could represent. Miniature <a href="https://www.google.com/search?q=gaming+tables&amp;safe=off&amp;source=lnms&amp;tbm=isch&amp;sa=X&amp;ved=0ahUKEwjNj5XXzv7ZAhVprFQKHUAvBAAQ_AUICygC&amp;biw=1920&amp;bih=1069">gaming tables</a> had created some amazing worlds and objects in that scale, and with the proper physicality and materials we could make the table seem &#39;luxe&#39;... and this gave us a good target for the art explorations in the months to come.</p>

<p>You&#39;ll note, of course, that we still hadn&#39;t settled on the &#39;table dragging&#39; method we have in our final product... we still were still serious about a turntable. The idea of a round board was compelling enough that the art team did a paintover of one of our rough city boards, and some concepts visualizing this round map set in a grand War Room. We stayed with this idea until the project got more of a team.</p>

<p><a href="https://gamasutra.com/db_area/images/Map_Paintover.jpg" target="_blank"><img alt="" src="https://gamasutra.com/db_area/images/Map_Paintover.jpg" style="height:174px; width:270px" /></a><a href="https://gamasutra.com/db_area/images/Room%20Planning%20Super%20Game%20Room.jpg" target="_blank"><img alt="" src="https://gamasutra.com/db_area/images/Room%20Planning%20Super%20Game%20Room.jpg" style="height:174px; width:300px" /></a></p>

<h2>Finalizing Table Movement with Oculus Touch</h2>

<p>Coming out of the early experiments, we had a better sense of the world scale we&#39;d be dealing with... Rather than playing at a nation level with major cities and a heavy economic component (as the Game of Thrones intro might have implied), we would have ramps, stairs, and buildings, and units that were a couple of inches high. However, our earliest prototypes still were created with a mouse acting as a proxy for a Touch controller... a right-click drag would move the world and a left-click would direct units. Once our project was officially approved, we could finally bring some real engineers (yay!) to really dig into world interaction.</p>

<p>We also had another issue that our initial turntable world presented... limited map size. We still wanted players to interact with units and towers very directly, by touching them if possible. However, if we stuck with the turntable layout and didn&#39;t want the player to be able to &#39;step into&#39; the table, we&#39;d be limited to a play space with only a few feet in diameter. Worse yet, the larger the table got, the further away the player might be from the action. As you can see from some very early table experiments in the video, we experiment with flat maps with grab-pull mechanics at times, but we had to gain a greater certainty that players would not feel uncomfortable. (Remember, this was two years ago and at the time comfort was priority number 1, 2&nbsp;<em>and&nbsp;</em>3 in VR).</p>

<p>Luckily, we were finally able to acquire some Oculus Touch controllers so the engineers could set up some real hands-on interaction... and the results were really great. We implemented the turntable movement successfully with the Touch controllers, but table movement by dragging a flat map was even more promising. The connection to the world that the player gained by physically dragging the map with their hands reduced discomfort immediately, eliminating the &#39;weird&#39; feeling of the table penetrating the body. Also, nausea was greatly reduced over the experiences we had moving the table with the mouse or via the stick. We were glad to know that we could deliver an experience with a map that was as large as we wanted, and more importantly we were happy that we could create units and interactions with intricate features that players could get up very close and appreciate.</p>

<p><img alt="" src="https://gamasutra.com/db_area/images/MapMoveHooks.gif" style="height:357px; width:638px" /></p>

<p>The last piece of the puzzle came as early testers were still seen struggling to move around the table. It was important to us to avoid 2D game crutches such as minimaps if possible, but it was critical for players to be able to move from conflict to conflict quickly. However, a segment of players still tended to &#39;crawl&#39; along the map as opposed to &#39;throwing&#39; it as intended. People&#39;s arms were getting tired because of how much motion was demanded... There was still doubt. Luckily, we observed that some of the more adept players tended to use their wrists as a fulcrum to get extra speed when releasing the map. This led to the addition of an &#39;extension&#39; to the player&#39;s hand (what we often called a &#39;hook&#39; that &#39;grabbed&#39; the map), which allowed players to amplify motion with a flick of the wrist. Finally most players were able to cruise from one end of the map to the other after only a minute or two of practice. This was the last piece in the puzzle that cemented the control system of Brass to be as intuitive and precise as we could manage.</p>

<p><em>Starting during this time and continuing into later months, there were new gameplay questions to be answered. We were happy with our table movement but the tension between creating controls that were both physical and responsive was just beginning. More on this next time.</em></p>

            </div>   
                                                <hr>
                    <div class="hide-phone">
                        <h3>Related Jobs</h3>
                                                   <div class="stories_item">
                                <div class="thumb"><a href="http://jobs.gamasutra.com/job/game-designer-economy-berlin-33223"><img src="https://d1506sp6x4e9z7.cloudfront.net/gamasutra/uploads/%26no_logo..jpg" alt="Wooga GmbH" width="120"></a></div>
                                <div class="title">
                                    <strong>
                                    Wooga GmbH &mdash; 
                                                                          Berlin,
                                                                                                            Germany
                                    <br />
                                    [08.09.18]
                                   </strong>
                                   <br />
                                   <a href="http://jobs.gamasutra.com/job/game-designer-economy-berlin-33223">Game Designer - Economy</a>
                                </div>
                           </div>
                                                   <div class="stories_item">
                                <div class="thumb"><a href="http://jobs.gamasutra.com/job/temporary-level-designer-champaign-illinois-33222"><img src="https://d1506sp6x4e9z7.cloudfront.net/gamasutra/uploads/983139.jpg" alt="Deep Silver Volition" width="120"></a></div>
                                <div class="title">
                                    <strong>
                                    Deep Silver Volition &mdash; 
                                                                          Champaign,
                                                                                                              Illinois,
                                                                        United States
                                    <br />
                                    [08.08.18]
                                   </strong>
                                   <br />
                                   <a href="http://jobs.gamasutra.com/job/temporary-level-designer-champaign-illinois-33222">Temporary Level Designer</a>
                                </div>
                           </div>
                                                   <div class="stories_item">
                                <div class="thumb"><a href="http://jobs.gamasutra.com/job/senior-level-designer-champaign-illinois-33221"><img src="https://d1506sp6x4e9z7.cloudfront.net/gamasutra/uploads/983139.jpg" alt="Deep Silver Volition" width="120"></a></div>
                                <div class="title">
                                    <strong>
                                    Deep Silver Volition &mdash; 
                                                                          Champaign,
                                                                                                              Illinois,
                                                                        United States
                                    <br />
                                    [08.08.18]
                                   </strong>
                                   <br />
                                   <a href="http://jobs.gamasutra.com/job/senior-level-designer-champaign-illinois-33221">Senior Level Designer</a>
                                </div>
                           </div>
                                                   <div class="stories_item">
                                <div class="thumb"><a href="http://jobs.gamasutra.com/job/director-of-design-burbank-california-32971"><img src="https://d1506sp6x4e9z7.cloudfront.net/gamasutra/uploads/944557.jpg" alt="Insomniac Games" width="120"></a></div>
                                <div class="title">
                                    <strong>
                                    Insomniac Games &mdash; 
                                                                          Burbank,
                                                                                                              California,
                                                                        United States
                                    <br />
                                    [08.08.18]
                                   </strong>
                                   <br />
                                   <a href="http://jobs.gamasutra.com/job/director-of-design-burbank-california-32971">Director of Design</a>
                                </div>
                           </div>
                                            </div>
                    <br class="clear"/><br/>
                    <div class="right small">
                        <strong>[<a href="http://jobs.gamasutra.com/">View All Jobs</a>]</strong>
                    </div>
                    <br class="clear"/><br/>
                                        <hr>
            							<script type='text/javascript'>
								
								//Rectangle 1 on small mobile device
								if (document.documentElement.clientWidth <= 767)
								{ document.write('<div id="div-gpt-ad-rec1"><center>'); googletag.display('div-gpt-ad-rec1'); document.write('</center></div>'); }
								
							</script>


                <div id="dynamiccomments">
					<span id="cmtArticleId" style="display:none">321208</span>
					<span id="cmtStory_type" style="display:none">blog</span>
					<span id="cmtArticleUri" style="display:none">/blogs/PatrickLipo/20180806/321208/Brass_Tactics_Evolving_classic_RTS_interactions_for_VR__Part_1.php?utm_source=feedburner&utm_medium=feed&utm_campaign=Feed%3A+GamasutraFeatureArticles+%28Gamasutra+Feature+Articles%29</span>
					<span id="author_id" style="display:none">2207</span>
					<span id="author_user_id" style="display:none">28892093</span>
                    <a style="font-weight: bold; font-size: 16px;" name="comments"> Loading Comments</a>
                    <br />
                    <hr noshade size="1" class="hr_comment">
                
                    <div align="center">
                         <img style="padding-top: 2px; padding-right: 5px; padding-bottom: 5px;" alt="loader image" src="/ajax-loader.gif"/>
                    </div>
       
                </div>
                    </div>  
        <!-- InstanceEndEditable -->
    </div><!--end contentbox-->
</div><!--end span-16-->

            </div>
            <br class="clear">
	</div><!--end span-21-->

        <!--begin right sidebar-->
     	<div class="hide-phone center">
               <div class="span-4 last">
                   <!--right hand ads start here-->

  
                            <!-- Beginning Sync AdSlot 7 for Ad unit Gamasutra/ ### size: [[160,600]]  -->
<div id='div-gpt-ad-sky1'>
 <script type='text/javascript'>
  googletag.display('div-gpt-ad-sky1');
 </script>
</div>
<!-- End AdSlot 7 -->
        <!-- Beginning Sync AdSlot 8 for Ad unit Gamasutra/ ### size: [[160,160]]  -->
<div id='div-gpt-ad-Ltile1'>
 <script type='text/javascript'>
  googletag.display('div-gpt-ad-Ltile1');
 </script>
</div>
<!-- End AdSlot 8 -->
      
		 
               	</div>
                 </div>
     <!--end right sidebar-->         
        </div>
					<!-- Beginning Sync AdSlot 21 for Ad unit Gamasutra/ ### size: [[8,2]]  -->
<div id='div-gpt-ad-native'>
 <script type='text/javascript'>
  googletag.display('div-gpt-ad-native');
 </script>
</div>
<!-- End AdSlot 21 -->
			<!-- Beginning Sync AdSlot 22 for Ad unit Gamasutra/ ### size: [[8,4]]  -->
<div id='div-gpt-ad-insight'>
 <script type='text/javascript'>
  googletag.display('div-gpt-ad-insight');
 </script>
</div>
<!-- End AdSlot 22 -->
			<!-- Beginning Sync AdSlot 23 for Ad unit Gamasutra/ ### size: [[4,4]]  -->
<div id='div-gpt-ad-video'>
 <script type='text/javascript'>
  googletag.display('div-gpt-ad-video');
 </script>
</div>
<!-- End AdSlot 23 -->
				
     </div><!--end container-->
     
     <br class="clear">
<link rel="stylesheet" type="text/css" href="https://twimgs.com/informationweek/footernav/jan2015/css/superfooter_dark.css" />
<div align="center">
          <!-- Beginning Sync AdSlot 6 for Ad unit Gamasutra/ ### size: [[3,3]]  -->
<div id='div-gpt-ad-ribbon'>
 <script type='text/javascript'>
  googletag.display('div-gpt-ad-ribbon');
 </script>
</div>
<!-- End AdSlot 6 -->
</div>
<!--begin footer-->
<!-- BEGIN DARK FOOTER -->
<div align="center">
  <div class="superfooter" id="footerblack">
    <div class="superfooter container" id="pagecenter">
    <div id="top">
    <!--DARK FOOTER LEFT SIDE -->
    <div  id="left">
    <a href="http://www.ubmtechweb.com/" target="_blank"><img src="https://twimgs.com/nojitter/gama/UBM_Logo_White.png" width="88" height="111" border="0" alt="UBM"></a>
    </div><!-- / DARK FOOTER LEFT SIDE -->
    <!-- DARK FOOTER rightlinks SIDE -->
    <div class="superfooter" id="rightlinks">
      <div class="list-div" id="tech-brands">
        <ul class="first-list">
          <li class="footer_title">TECHNOLOGY GROUP</li> 
          <li><a href="http://www.blackhat.com/" target="_blank">Black Hat</a></li>
<li><a target="_blank" href="http://contentmarketinginstitute.com/">Content Marketing Institute</a></li>
<li><a target="_blank" href="http://www.contentmarketingworld.com/">Content Marketing World</a></li>
          <li><a href="http://www.darkreading.com/" target="_blank">Dark Reading</a></li> 
         
        </ul>
        <ul>
          <li><a target="_blank" href="http://www.enterpriseconnect.com/">Enterprise Connect</a></li>
          <li><a href="http://www.gdconf.com/" target="_blank">GDC</a></li>
          <li><a href="/" target="_blank">Gamasutra</a></li>
		  <li><a href="http://www.thinkhdi.com/" target="_blank">HDI</a></li>
        </ul>
        <ul>
          <li><a href="http://www.icmi.com/" target="_blank">ICMI</a></li>
          <li><a href="http://www.informationweek.com/" target="_blank">InformationWeek</a></li>
		  <li><a href="http://insecurity.com/" target="_blank">INsecurity</a></li>
		  <li><a href="http://www.interop.com" target="_blank">Interop ITX</a></li>
        </ul>
        <ul class="last-list">
          <li><a href="http://www.networkcomputing.com/" target="_blank">Network Computing</a></li>
          <li><a href="http://www.nojitter.com/" target="_blank">No Jitter</a></li>
		  <li><a href="http://www.smworld.com/" target="_blank">Service Management World</a></li>
		  <li><a href="http://www.vrdconf.com/" target="_blank">VRDC</a></li>
        </ul>
      </div>
      <div class="list-div" id="communities-served">
        <ul class="first-list">
          <li class="footer_title">COMMUNITIES SERVED</li>
<li><a target="_blank" href="http://tech.ubm.com/community-brands/content-marketing-2/">Content Marketing</a></li>

          <li><a href="http://tech.ubm.com/community-brands/enterprise-it/" target="_blank">Enterprise IT</a></li>
          <li><a href="http://tech.ubm.com/community-brands/enterprise-communications/" target="_blank">Enterprise Communications</a></li>
          <li><a href="http://tech.ubm.com/community-brands/game-and-app-developers/" target="_blank">Game Development</a></li>
          <li><a href="http://tech.ubm.com/community-brands/information-security/" target="_blank">Information Security</a></li>
          <li><a href="http://tech.ubm.com/community-brands/technical-service-and-support/" target="_blank">IT Services & Support</a></li>
       </ul>
      </div>
      <div class="list-div" id="working-with-us">
        <ul class="first-list">
          <li class="footer_title">WORKING WITH US</li>
          <li><a href="http://createyournextcustomer.techweb.com/contact-us/" target="_blank">Advertising Contacts</a></li>
          <li><a href="http://events.ubm.com/?company=10" target="_blank">Event Calendar</a></li>
          <li><a href="http://createyournextcustomer.techweb.com/" target="_blank">Tech Marketing</a></li>
          <li><a href="http://createyournextcustomer.techweb.com/" target="_blank">Solutions</a></li>
          <li><a href="http://tech.ubm.com/contact-us/" target="_blank">Contact Us</a></li>
          <li><a href="http://wrightsmedia.com/sites/ubm/index.cfm" target="_blank">Licensing</a></li>
        </ul>
      </div>
    </div><!-- / DARK FOOTER rightlinks -->
  </div><!--end top-->
    <div style="clear:both;"></div><!-- // to clear the right and left evenly // -->
  <div  id="bottom">
    <ul class="blue">
      <li><a href="http://legal.us.ubm.com/terms-of-service/" target="_blank" class="blue">Terms of Service</a></li>
      <li><a href="http://legal.us.ubm.com/privacy-policy/" target="_blank" class="blue">Privacy Statement</a></li>
  <li><a href="http://reg.ubmamevents.com/UBMLegalEntities" target="_blank" class="blue">Legal Entities</a></li> 
      <li>Copyright &#169; 2018 UBM, All rights reserved</li>
    </ul>
  </div>
    </div>
  </div><!-- / END footergrey -->
</div><!-- / END align="center" -->
<!-- / END DARK FOOTER -->

<!-- Eloqua tracking code -->
<SCRIPT TYPE='text/javascript' LANGUAGE='JavaScript' SRC='https://twimgs.com/nojitter/gama/js/elqtracking.js'></SCRIPT>
<SCRIPT TYPE='text/javascript' LANGUAGE='JavaScript' SRC='https://twimgs.com/informationweek/elqNow/elqCfg.js'></SCRIPT><SCRIPT TYPE='text/javascript' LANGUAGE='JavaScript' SRC='https://twimgs.com/informationweek/elqNow/elqImg.js'></SCRIPT>
<!-- End Eloqua tracking code -->

<script type="text/javascript" src="https://ins.techweb.com/beacon/js/beacon-min.js"></script>
<script type="text/javascript">
var beacon = new UBM.Beacon({environment: 'p', apiKey: '31fa8154ead6bb6b2bcefa32b0b2bd86ef990485d4def29a6117223512da2973'});
beacon.pageview();
</script>
<script type="text/javascript">
	var registerData='';
	registerCheck();
	function registerCheck(){
		$.ajax({
			url: '/omnloginstatus.php',
			async : false,
			success: function(result){
				registerData = result.replace('"','');
				registerData = registerData.replace('"','');
			}
		});
	}
</script>

<script type="text/javascript" src="https://twimgs.com/gamasutra/js/combined.js"></script>
<script type="text/javascript" src="https://twimgs.com/nojitter/gama/js/nextgengama.js?v5"></script>
<script type="text/javascript" src="https://twimgs.com/nojitter/gama/js/checkauth.js?v2"></script>
<script type="text/javascript" src="https://twimgs.com/nojitter/gama/js/oasTrack_v1.js"></script>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
<script type="text/javascript" src="https://apis.google.com/js/plusone.js"></script>
<!-- SiteCatalyst code version: H.21.
Copyright 1996-2010 Adobe, Inc. All Rights Reserved
More info available at http://www.omniture.com -->


<script language="JavaScript" type="text/javascript" src="https://epromos.ubmcanon.com/VisitorAPI.js?ormzkk"></script>
<script language="JavaScript" type="text/javascript" src="https://epromos.ubmcanon.com/s_code/ubm-tech-global-app-measurement.js"></script>
<script language="JavaScript" type="text/javascript"><!--
    /* You may give each page an identifying name, server, and channel on
    the next lines. */
	s.pageName="";
	s.server="";
	s.channel="";
	s.pageType="";
	s.prop1="";
	s.prop2="321208";
	s.prop3="Gamasustra | 321208 | Brass Tactics: Evolving classic RTS interactions for VR - Part 1";
	s.prop4="Brass Tactics: Evolving classic RTS interactions for VR - Part 1";
	s.prop5="GAMASUTRA BLOG";
	s.prop6="";
	s.prop7="Patrick Lipo";
	s.prop8="userAgent";
	s.prop9="";
	s.prop10="";
	s.prop13="";
    s.prop19=registerData;
	s.contextData['Newsletter_signup'] ="";
	/* Conversion Variables */
	s.campaign="";
	s.state="";
	s.zip="";
	s.events="event5";
	s.products="";
	s.purchaseID="";
	s.eVar1="design,vr";
	s.eVar2="";
	s.eVar3="";
	s.eVar4="";
	s.eVar5="";
	/************* DO NOT ALTER ANYTHING BELOW THIS LINE ! **************/
    var s_code = s.t(); if (s_code) document.write(s_code)//--></script>
<script language="JavaScript" type="text/javascript"><!--
    if (navigator.appVersion.indexOf('MSIE') >= 0) document.write(unescape('%3C') + '\!-' + '-')
//--></script><noscript><a href="http://www.omniture.com" title="Web Analytics"><img
src="http://cmp.112.2o7.net/b/ss/cmpglobalvista/1/H.21--NS/0"
height="1" width="1" border="0" alt="" /></a></noscript><!--/DO NOT REMOVE/-->
<!-- End SiteCatalyst code version: H.21. -->          
  
<!-- Begin ADSNATIVE Code -->
<script type="text/javascript" src="https://static.adsnative.com/static/js/render.v1.js"></script>
<!-- End ADSNATIVE Code -->  
<!--Begin Ad script for pixel --> 

<script type="text/javascript">
    adroll_adv_id = "AJSB6AWABZB2RFHAOYSOZH";
    adroll_pix_id = "2RTKKW6YFBHIVKRM6FNJ4D";
    /* OPTIONAL: provide email to improve user identification */
    /* adroll_email = "username@example.com"; */
    (function () {
        var _onload = function(){
            if (document.readyState && !/loaded|complete/.test(document.readyState)){setTimeout(_onload, 10);return}
            if (!window.__adroll_loaded){__adroll_loaded=true;setTimeout(_onload, 50);return}
            var scr = document.createElement("script");
            var host = (("https:" == document.location.protocol) ? "https://s.adroll.com" : "http://a.adroll.com");
            scr.setAttribute('async', 'true');
            scr.type = "text/javascript";
            scr.src = host + "/j/roundtrip.js";
            ((document.getElementsByTagName('head') || [null])[0] ||
                document.getElementsByTagName('script')[0].parentNode).appendChild(scr);
        };
        if (window.addEventListener) {window.addEventListener('load', _onload, false);}
        else {window.attachEvent('onload', _onload)}
    }());
</script>

<!--END Ad script for pixel -->
</body>
</html>                
                