<!doctype html>
<html lang="en">
<head>
  <!-- Google Tag Manager -->
  <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
  new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
  j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
  'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
  })(window,document,'script','dataLayer','GTM-NDKS786');</script>
  <!-- End Google Tag Manager -->
  
	        <!-- <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" /> -->
		<meta http-equiv='Content-Type' content='text/html; charset=UTF-8' /> 
		<title>Gamasutra: Adam Foster's Blog - Alternate Reality Game puzzle design</title>
	<meta name="pagecaching" content="806" />
			<meta name="keywords" content="game development, game developer, game programming, game programmer, videogame, artificial intelligence, 3D animation, game design, 3D modeling, game business, game jobs, game directory, game development software, game technology, 3D technology, game producer, game audio, game animation, virtual reality, digital entertainment, PC game, Xbox game, game news, new game, arcade development, Nintendo development, Playstation development, Playstation 2, PS2, Dreamcast development, Game Developer magazine, Computer Game Developers Conference, Game Developers Conference, Independent Game Developers Conference, CMP Game Media Group, game industry research, online game development, digital assets, free textures, free 3D models, free shaders, Gamasutra Exchange, 3D Studio Max textures" /><meta name="description" content="Or, how to make impossibly complicated puzzles that people can solve." />
		<!--[if lt IE 9]>
		<script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script>
	<![endif]-->
	<style>
		
			.cke_source{
				white-space:normal !important;
			}
			.hide_phone > iframe {
				width: 100%;
			}
			@media only screen and (max-width:479px){
				.hide_phone > iframe {
					height: auto;
				}
				.embeddedContent iframe, .page_data_1 iframe {
					width: 100%;
				}
			}
			.properties ul li {
				padding: 5px 28px !important;
			}
			.formElement label.questionLabel p.description {
				font-weight: normal;
				padding: 0 !important;
			}
			div#rightlinks ul {
				padding: 0 15px !important;
			}
			.article img {
				max-width: 100% !important;
			}
			@media screen and (max-width: 425px) {
				blockquote{
					float:none !important;
					clear:both;
				}
			}
		

	</style>
	<!-- CSS -->
        
        
<meta property="fb:app_id" content="1424004174373289"/>		
        			 <meta property="og:type" content="article"/>
			 <meta property="og:url"  content="https://www.gamasutra.com/blogs/AdamFoster/20130617/194321/Alternate_Reality_Game_puzzle_design.php" />
			 <meta property="og:title" content="Alternate Reality Game puzzle design" />
                   	 	
                                <meta name="og:image" content="https://www.gamasutra.com/blogs/edit/img/portrait/939620/portrait.jpg" />
                         			 <meta property="og:description" content="Or, how to make impossibly complicated puzzles that people can solve." />
				
		<meta name="twitter:card" content="summary" />
		<meta name="twitter:site" content="@gamasutra" />
		<meta name="twitter:creator" content="@gamasutra" />
					<meta name="twitter:title" content="Alternate Reality Game puzzle design" />
			<meta name="twitter:description" content="Or, how to make impossibly complicated puzzles that people can solve." />
			<meta name="twitter:creator" content="@gamasutra" />
			<meta name="twitter:url" content="https://www.gamasutra.com/blogs/AdamFoster/20130617/194321/Alternate_Reality_Game_puzzle_design.php" />
			<meta name="twitter:image" content="https://www.gamasutra.com/blogs/edit/img/portrait/939620/portrait.jpg" />
		
        
                	<link rel="canonical" href="https://www.gamasutra.com/blogs/AdamFoster/20130617/194321/Alternate_Reality_Game_puzzle_design.php" />
                <link rel="alternate" type="application/rss+xml" title="Gamasutra Article Feed" href="https://feeds.feedburner.com/GamasutraFeatureArticles/" />
        <link rel="alternate" type="application/rss+xml" title="Gamasutra News Feed" href="https://feeds.feedburner.com/GamasutraNews/" />
        <link rel="alternate" type="application/rss+xml" title="Gamasutra Columns Feed" href="https://feeds.feedburner.com/GamasutraColumns/" />
        <link rel="alternate" type="application/rss+xml" title="Gamasutra Jobs Feed" href="https://feeds.feedburner.com/GamasutraJobs/" />
        <!-- link href="https://twimgs.com/gamasutra/css/minified.css" rel="stylesheet" type="text/css" / -->
        <link href="https://twimgs.com/nojitter/gama/css/gama_unminified.css?v1" rel="stylesheet" type="text/css" />
		<style>
			
				#div-gpt-ad-Ltile1 {
					margin-top: 10px;
				}
			
		</style>
        
                         <meta name="node" content="Gama1"/>
            
        <meta name="pagecaching" content="701"/>
        		<script language="JavaScript" type="text/javascript" src="https://twimgs.com/custom/library.gtecevent.com/assets/VisitorAPI.js?ormzkk"></script>
    <script type="text/javascript" src="https://twimgs.com/custom/library.gtecevent.com/assets/at.js?ormzkk"></script>
        <script type="text/javascript" src="https://twimgs.com/nojitter/gama/js/redesign_comments.js"></script>
		<script src="//code.jquery.com/jquery-1.8.2.min.js"></script>
		<script type="text/javascript" async src="https://cdnjs.cloudflare.com/ajax/libs/mathjax/2.7.5/MathJax.js?config=TeX-MML-AM_CHTML"></script>
    <script type="text/javascript" src="https://twimgs.com/gamasutra/js/combined.js"></script>
    <script type="text/javascript" src="https://twimgs.com/nojitter/gama/js/nextgengama.js?v5"></script>
    <script type="text/javascript" src="https://twimgs.com/nojitter/gama/js/checkauth.js?v11"></script>
		<script type="text/javascript"> 
        
		function checkMail(obj){
	 
		   var think_opt_out = document.getElementById('Think_Opt_Out');
	 
		   if (document.getElementById('Think_Opt_Out').checked) {
	 
				 document.getElementById('Think_Opt_In').value = 0;
		   } else {
	 
				 document.getElementById('Think_Opt_In').value = 1;
		   }
		   var firstname = document.getElementById('firstname').value;
		   if (firstname == ""){
				 alert('Please provide your first name');
				 return false;
		   }
	 
		   if (document.getElementById('lastname').value == ''){
				 alert("Please provide your lastt name");
				 return false;
		   }
	 
	 
		   var x = document.getElementById('EmailAddr').value;
	 
		   var filter  = /^([a-zA-Z0-9_\.\-])+\@(([a-zA-Z0-9\-])+\.)+([a-zA-Z0-9]{2,4})+$/;
		   if (filter.test(x)) { return true; }
		   else  { alert('Invalid Email Address detected. Please correct.'); return false; }
	 
	 
		}
		 
		</script>
        <script type="text/javascript" src="https://twimgs.com/gamasutra/js/md5.js"></script>

        

        <script type="text/javascript">
        var adrand = parseInt(Math.random()*1000000000, 10);
        var adkeys = "key1+key2+key3+key4";
        </script>

        	<!-- Mobile Specific Metas -->
	<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1" /> 
	
	<script type="text/javascript">
            
		var browser			= navigator.userAgent;
		var browserRegex	= /(Android|BlackBerry|IEMobile|Nokia|iP(ad|hone|od)|Opera M(obi|ini))/;
		var isMobile		= false;
		if(browser.match(browserRegex)) {
			isMobile			= true;
			
		}
        
	</script>
        <!-- Start Visual Website Optimizer Asynchronous Code -->
        <script type='text/javascript'>
        
        var _vwo_code=(function(){
        var account_id=32069,
        settings_tolerance=2000,
        library_tolerance=2500,
        use_existing_jquery=false,
        // DO NOT EDIT BELOW THIS LINE
        f=false,d=document;return{use_existing_jquery:function(){return use_existing_jquery;},library_tolerance:function(){return library_tolerance;},finish:function(){if(!f){f=true;var a=d.getElementById('_vis_opt_path_hides');if(a)a.parentNode.removeChild(a);}},finished:function(){return f;},load:function(a){var b=d.createElement('script');b.src=a;b.type='text/javascript';b.innerText;b.onerror=function(){_vwo_code.finish();};d.getElementsByTagName('head')[0].appendChild(b);},init:function(){settings_timer=setTimeout('_vwo_code.finish()',settings_tolerance);this.load('//dev.visualwebsiteoptimizer.com/j.php?a='+account_id+'&u='+encodeURIComponent(d.URL)+'&r='+Math.random());var a=d.createElement('style'),b='body{opacity:0 !important;filter:alpha(opacity=0) !important;background:none !important;}',h=d.getElementsByTagName('head')[0];a.setAttribute('id','_vis_opt_path_hides');a.setAttribute('type','text/css');if(a.styleSheet)a.styleSheet.cssText=b;else a.appendChild(d.createTextNode(b));h.appendChild(a);return settings_timer;}};}());_vwo_settings_timer=_vwo_code.init();
        
        </script>
        <!-- End Visual Website Optimizer Asynchronous Code -->
       
        
        <!-- Start HeatMap.me Code -->
		<script type='text/javascript'>
		(function(h,e,a,t,m,p)
		{ m=e.createElement(a);m.async=!0;m.src=t; p=e.getElementsByTagName(a)[0];p.parentNode.insertBefore(m,p); }
		)(window,document,'script','https://u.heatmap.it/log.js');
		</script>
		<!-- End HeatMap.me Code -->
        
        
				
		<!-- Start: GPT Sync -->
        <script>
		
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
        googletag.slots = googletag.slots || {};
        var gptadslots=[];
		
        </script>
        <script src="//www.googletagservices.com/tag/js/gpt.js"></script>

        <script type="text/javascript">
              
                      googletag.pubads().setTargeting('kw',['design']);
                                            googletag.pubads().setTargeting('aid',['194321']);
          		
				if (document.documentElement.clientWidth > 767)
				{
				//Adslot 19 declaration
		
					gptadslots[19]=googletag.defineSlot('/2441/Gamasutra',[[2,2]],'div-gpt-ad-welcome').setTargeting('pos',['welcome']).setTargeting('testAd',['']).addService(googletag.pubads());
		
				}
				else
				{
				//Adslot 20 declaration
		
					gptadslots[20]=googletag.defineSlot('/2441/Gamasutra',[[7,7]],'div-gpt-ad-mi').setTargeting('pos',['mi']).setTargeting('testAd',['']).addService(googletag.pubads());
		
				}
				  
		
				if (document.documentElement.clientWidth > 767){//Adslot 3 declaration
		
					gptadslots[1]= googletag.defineSlot('/2441/Gamasutra', [[1,2]],'div-gpt-ad-skin').setTargeting('pos',['skin']).setTargeting('testAd',['']).addService(googletag.pubads());

					gptadslots[2]= googletag.defineSlot('/2441/Gamasutra', [[728,90]],'div-gpt-ad-top').setTargeting('pos',['top']).setTargeting('testAd',['']).addService(googletag.pubads());
		
				}else{ 
		
					gptadslots[13]= googletag.defineSlot('/2441/Gamasutra', [[300,50]],'div-gpt-ad-mobile_leaderboard').setTargeting('pos',['mobile_leaderboard']).setTargeting('testAd',['']).addService(googletag.pubads());
		

		}
		            
          //Adslot 1 declaration
       

				  //Adslot 2 declaration
		
				if (document.documentElement.clientWidth > 767){//Adslot 3 declaration
		

					 //Adslot 3 declaration
					 gptadslots[3]= googletag.defineSlot('/2441/Gamasutra', [[164,59]],'div-gpt-ad-button1').setTargeting('pos',['button1']).setTargeting('testAd',['']).addService(googletag.pubads());

					 //Adslot 4 declaration
					 gptadslots[4]= googletag.defineSlot('/2441/Gamasutra', [[164,59]],'div-gpt-ad-button2').setTargeting('pos',['button2']).setTargeting('testAd',['']).addService(googletag.pubads());

					 //Adslot 5 declaration
					 gptadslots[5]= googletag.defineSlot('/2441/Gamasutra', [[164,409]],'div-gpt-ad-callout').setTargeting('pos',['callout']).setTargeting('testAd',['']).addService(googletag.pubads());
		

				}
		
						
			//Adslot 6 declaration
			gptadslots[6]= googletag.defineSlot('/2441/Gamasutra', [[300,250]],'div-gpt-ad-rec1').setTargeting('pos',['rec1']).addService(googletag.pubads());
						
		
				if (document.documentElement.clientWidth > 767){//Adslot 3 declaration
		

					 //Adslot 7 declaration
					 gptadslots[7]= googletag.defineSlot('/2441/Gamasutra', [[160,600]],'div-gpt-ad-sky1').setTargeting('pos',['sky1']).setTargeting('testAd',['']).addService(googletag.pubads());

					 //Adslot 8 declaration
					 gptadslots[8]= googletag.defineSlot('/2441/Gamasutra', [[160,160]],'div-gpt-ad-Ltile1').setTargeting('pos',['Ltile1']).setTargeting('testAd',['']).addService(googletag.pubads());

					 //Adslot 9 declaration
					 gptadslots[9]= googletag.defineSlot('/2441/Gamasutra', [[164,177]],'div-gpt-ad-custom1').setTargeting('pos',['custom1']).setTargeting('testAd',['']).addService(googletag.pubads());

					
					 //Adslot 11 declaration
					 gptadslots[11]= googletag.defineSlot('/2441/Gamasutra', [[164,177]],'div-gpt-ad-custom3').setTargeting('pos',['custom3']).setTargeting('testAd',['']).addService(googletag.pubads());
					  
          
		
		}
		
		 gptadslots[14]= googletag.defineSlot('/2441/Gamasutra', [[3,3]],'div-gpt-ad-ribbon').setTargeting('pos',['ribbon']).setTargeting('testAd',['']).addService(googletag.pubads());
		 		 		 													//Adslot 21 declaration
			gptadslots[21]=googletag.defineSlot('/2441/Gamasutra',[[8,2]],'div-gpt-ad-native').setTargeting('pos',['native']).setTargeting('testAd',['']).addService(googletag.pubads());
			//Adslot 22 declaration
			gptadslots[22]=googletag.defineSlot('/2441/Gamasutra',[[8,4]],'div-gpt-ad-insight').setTargeting('pos',['insight']).setTargeting('testAd',['']).addService(googletag.pubads());
			//Adslot 23 declaration
			gptadslots[23]=googletag.defineSlot('/2441/Gamasutra',[[4,4]],'div-gpt-ad-video').setTargeting('pos',['video']).setTargeting('testAd',['']).addService(googletag.pubads());
		

         googletag.pubads().enableSingleRequest();
		 googletag.pubads().collapseEmptyDivs();
         		 googletag.pubads().enableAsyncRendering();
         googletag.enableServices();
        </script>
        <!-- End: GPT -->
	
	<script type="text/javascript">
	
	  var _AdsNativeOpts =
	  {
	
		keywords: ['']
	
	  };
	
	</script>
        
         		<script type="text/javascript">
 		
			var _gaq = _gaq || [];
			_gaq.push(['_setAccount', 'UA-48094207-1']);
			_gaq.push(['_trackPageview']);
			(function()
			{ var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true; ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js'; var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s); }
			)();
		
		</script>
		<link rel="stylesheet" href="https://i.ubm-us.net/oas/nativead/css/game_nativead.css" />
		<script language="JavaScript" src="https://i.ubm-us.net/oas/nativead/js/nativead.js"></script>
		<script language="JavaScript" src="https://i.ubm-us.net/oas/nativead/js/game_nativead.js"></script>
		<link rel="stylesheet" href="https://twimgs.com/nojitter/gama/css/informa-iribbon.css" />
	<script src="https://twimgs.com/nojitter/gama/js/informa-iribbon.js"></script>
	<script type="text/javascript" src="https://twimgs.com/nojitter/gama/js/cookie_banner.js"></script>
	<link rel="stylesheet" href="https://img.deusm.com//darkreading/cookie_banner_css.css" />
	
<!-- Eloqua tracking code -->
<script type='text/javascript' language='JavaScript'>
var _elqQ = _elqQ || [];
_elqQ.push(['elqSetSiteId', '2150']);
_elqQ.push(['elqUseFirstPartyCookie', 'trk.gamasutra.com']);
_elqQ.push(['elqTrackPageView']);

(function () {
function async_load() {
    var s = document.createElement('script'); s.type = 'text/javascript'; s.async = true;
    s.src = '//img.en25.com/i/elqCfg.min.js';
    var x = document.getElementsByTagName('script')[0]; x.parentNode.insertBefore(s, x);
}
if (window.addEventListener) window.addEventListener('DOMContentLoaded', async_load, false);
else if (window.attachEvent) window.attachEvent('onload', async_load); 
})();
</script>
<!-- End Eloqua tracking code -->	
</head>
<body >
  <!-- Google Tag Manager (noscript) -->
  <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-NDKS786" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
  <!-- End Google Tag Manager (noscript) -->
	<!--Cookie banner code starts here -->
	<div id="gdpr_banner" style="display:none;">
	<div id = "cookie">
	<div class="gdpr-popup-border">
	<div class="gdrp-popup-content">
		<div id="popup-text">This site uses cookies to provide you with the best user experience possible. By using Gamasutra, you accept <a href="https://tech.informa.com/cookie-policy" target="_blank">our use of cookies.</a></div>
		<div id="popup-buttons"><span class="close-button" >&times;</span></div>
	</div>
	</div>
	</div>
	</div>
	<!--Cookie banner code ends here -->
	<!-- Informa Branding code goes here-->
	<div id="iribbon-container" class="content-body-wrapper" style="padding-top:10px; opacity:0;">
			<button id="iribbon-title" title="show/hide" class="inactive">Informa</button>
			<div id="iribbon-detail" class="ribbon-hide" style="">
    		<div id="iribbon-left">
        		<p>Gamasutra is part of the Informa Tech Division of Informa PLC</p>
        		<ul>
            		<li class="iribbon-mainlink"><a href="https://informa.com/" tabindex="-1" class='iribbon-opacity-out'>Informa PLC</a></li>
            		<li><a href="https://informa.com/About-Us/" tabindex="-1" class='iribbon-opacity-out'>About us</a></li>
            		<li><a href="https://informa.com/Investors/" tabindex="-1" class='iribbon-opacity-out'>Investor relations</a></li>
            		<li><a href="https://informa.com/Talent/" tabindex="-1" class='iribbon-opacity-out'>Talent</a></li>
        		</ul>
    		</div>
    			<div id="iribbon-right">
        			<p>This site is operated by a business or businesses owned by Informa PLC and all copyright resides with them. Informa PLC's registered office is 5 Howick Place, London SW1P 1WG. Registered in England and Wales. Number 8860726.</p>
    			</div>
			</div>
	</div>
	<!-- Informa Branding code goes here-->
	<!-- Beginning Sync AdSlot 19 for Ad unit Gamasutra/ ### size: [[2,2]]  -->
<div id='div-gpt-ad-welcome'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-welcome');
	}
	);
 </script>
</div>
<!-- End AdSlot 19 -->
	<!-- Beginning Sync AdSlot 20 for Ad unit Gamasutra/ ### size: [[7,7]]  -->
<div id='div-gpt-ad-mi'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-mi');
	}
	);
 </script>
</div>
<!-- End AdSlot 20 -->
    <div class="hide-phone">
                                <!-- Beginning Sync AdSlot 1 for Ad unit Gamasutra/ ### size: [[1,2]]  -->
<div id='div-gpt-ad-skin'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-skin');
	}
	);
 </script>
</div>
<!-- End AdSlot 1 -->
            </div>
	
	<div class="container"> 
	<div id="container-main" class="content-body-wrapper" style="opacity:0;">
	<script src="/prestitial/adblockDetector.js"></script>
	<!-- Google Prestitial Ads start here-->
	<script>
	  
	  var isblocked = "notblocked";
	  if(!document.getElementById('xRokYeIsHL')){
	   isblocked = "blocked";
	  }
	  console.log('lpage==>' + isblocked);
	  if (isblocked == "notblocked") {
		setTimeout(function() {
		console.log('5 second timeout ');
		unhideMainContent();
		}, 5000);
		googletag.pubads().addEventListener('slotRenderEnded', function(event) {
		  if(event.slot.getSlotElementId() == "div-gpt-ad-welcome")
			{
			console.log('interstitial unit found');
			if(event.isEmpty) {
			  console.log('empty Interstitial');
			   unhideMainContent();
			}
			else {
			  console.log('not empty Interstitial');
			}
		  }
		});
		googletag.enableServices();
	  }else{
		  unhideMainContent();
	  }
	function unhideMainContent() {
		console.log('unhide main content');
		var bDiv = document.getElementsByClassName("content-body-wrapper");

		for (var i=0; i<bDiv.length; i++) {
		  if(bDiv[i].style.removeProperty) {
		   bDiv[i].style.removeProperty('opacity');
		  } 
		  else {
			bDiv[i].style.removeAttribute('opacity');
		  }
		}
	}
	
	</script>
	<!-- Google  Prestitial Ads end here-->
	
    <div class="hide-phone">
         <div class="wrapper properties">
            
		
         </div><!--end wrapper-->
    </div>
    
    <br />
     <div class="container bottom3">
     	<div class="span-7">
          	<a href="https://www.gamasutra.com"><img src="https://twimgs.com/gamasutra/images/gamasutra_logo.png" alt="Gamasutra: The Art &amp; Business of Making Games" width="243" height="77" border="0" /></a><img alt="spacer" src="https://twimgs.com/gamasutra/images/spacer.gif" width="27" />
		</div>
          <div class="hide-phone">
              <div class="div span-16 last leaderboard">
                     
                                                                               <!-- Beginning Sync AdSlot 2 for Ad unit Gamasutra/ ### size: [[728,90]]  -->
<div id='div-gpt-ad-top'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-top');
	}
	);
 </script>
</div>
<!-- End AdSlot 2 -->
                                           
    
              </div>
          </div>
    </div>

		<div class="span-20">
			<div class="show-phone clearfix" style="padding:0px 0 5px 0"><!--sadie change-->
                        <div class="span-5 center ">
								<!-- Beginning Sync AdSlot 2 for Ad unit Gamasutra/ ### size: [[300,50]]  -->
<div id='div-gpt-ad-mobile_leaderboard'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-mobile_leaderboard');
	}
	);
 </script>
</div>
<!-- End AdSlot 2 -->

                        </div>
				</div>

                    <div class="show-phone"><!--there is another on the page for the regular size, this is phone only-->
                         <div class="span-5 last nav_search">
                              <div class="content center">
                                   <span class="nav_searchtxt">SEARCH</span>
                                   <form class="left" name="topsearchph" action="/search/" method="GET">
          
                                               <input name="search_text" type="text" size="25" class="search" />	  
                                              <span class="nav_searchbutton"><a href="" onClick="javascript: document.topsearchph.submit(); return false;">GO</a></span>
                                   
                                   </form>
                              </div>
                         </div>
                    </div><!--end show phone-->
                    
                    <div class="show-phone"><!--sadie change-->
                        <div class="span-3">
                                  <div class="login_phone" id="login_phone">
                                       
                                   </div>
                        </div>
                    </div><!--end showphone-->
                    <div class="nav">
                	<div class="span-3 nav_jobs">
                    	<div class="content">
                              <a href="https://jobs.gamasutra.com/">GAME JOBS</a>
                          </div>
                    </div>
                    <div class="span-12 nav_links">
                         <div class="content">
                                   <a href="/updates/">updates</a>
                                   <a href="/blogs/">Blogs</a>
                                   
                                   <a href="/contractors/contractor_display.php">contractors</a>
                                   <a href="/newsletter-signup">newsletter</a>
                                   <a target="_blank" href="https://www.gamecareerguide.com" style="color:#664271;">Game Career Guide</a>
                         </div>
                    </div>
                    <div class="hide-phone">
                        <div class="span-5 last nav_search">
                             <div class="content">
                                  <span class="nav_searchtxt">SEARCH</span>
                                  <form class="left" name="topsearch" action="/search/" method="GET">

                                              <input name="search_text" type="text" size="10" class="search" />	  
                                             <span class="nav_searchbutton"><a href="" onClick="javascript: document.topsearch.submit(); return false;">GO</a></span>

                                    </form>
                             </div>
                        </div>
                    </div>
                    <br class="clear">
               </div><!--end nav-->
               <div class="hide-phone"> 
                    <div class="span-20 last"> 
                       <div class="topicmenu">
                            <ul>
                                <li class="activetab"><a href="https://www.gamasutra.com">ALL</a>
                                </li><li ><a href="/topic/console-pc">CONSOLE/PC</a>
                                </li><li ><a href="/topic/smartphone-tablet">SMARTPHONE/TABLET</a>
                                </li><li ><a href="/topic/indie">INDEPENDENT</a>
                                </li><li ><a href="/topic/vr">VR/AR</a>
                                </li><li ><a href="/topic/social-online">SOCIAL/ONLINE</a>
                                </li></ul>
                                                          <span class="gdmag"><a href="/resourcecenter"><img src="https://twimgs.com/nojitter/gama/image/btn_gdmag1.png" width="118px" height="33px"></a></span>
                       </div>
                   </div>
               </div>		
                    <div class="span-20 last content_bg">
                        <div class="hide-phone">
<div class="span-4">
  <div class="content_box_left">
    <div class="leftcol">
        <!--member login-->
                    <table width="166" border="0" cellspacing="0" cellpadding="0">
  <tr>
    <td id="memberLogin" class="welcome">
    </td>
  </tr>
</table>                 <!--end memberlogin-->
        
        <!--begin social icons-->
            <!--begin social icons-->
<div  class="bottom2">
    <ul class="leftcol_social">
       <li class="facebook"><a href="https://www.facebook.com/pages/Gamasutra/31610613408" target="_blank">&nbsp;</a></li>
       <li class="twitter"><a href="https://twitter.com/gamasutra" target="_blank">&nbsp;</a></li>
       <li class="feed"><a href="https://www.gamasutra.com/static2/rssfeeds.html">&nbsp;</a></li>
       <li class="newsletter"><a href="/newsletter-signup">&nbsp;</a></li>
    </ul>
</div>
<!--end social icons-->        <!--end social icons-->
        
        <!--begin page numbers-->
                <!--end page numbers-->
        
        <!--begin leftnav-->
                <div class="leftnav_categories bottom2">
   <a href="/category/programming/"><img alt="arrow" src="https://twimgs.com/gamasutra/images/button_programming.gif"  width="24px" height="24px" /></a>
   <div class="leftnav_btn"><a href="/category/programming/">PROGRAMMING</a></div>

   <hr>

   <a href="/category/art/"><img alt="spacer" src="https://twimgs.com/gamasutra/images/button_art.gif" width="24px" height="24px" /></a>
   <div class="leftnav_btn"><a href="/category/art/">ART</a></div>

   <hr>

   <a href="/category/audio/"><img alt="spacer" src="https://twimgs.com/gamasutra/images/button_audio.gif" width="24px" height="24px"  /></a>         
   <div class="leftnav_btn"><a href="/category/audio/">AUDIO</a></div>

   <hr>

   <a href="/category/design/"><img alt="arrow" src="https://twimgs.com/gamasutra/images/button_design.gif" width="24px" height="24px"  /></a>
   <div class="leftnav_btn"><a href="/category/design/">DESIGN</a></div>

   <hr>

   <a href="/category/production/"><img alt="arrow" src="https://twimgs.com/gamasutra/images/button_production.gif" width="24px" height="24px" /></a>
   <div class="leftnav_btn"><a href="/category/production/">PRODUCTION</a></div>

   <hr>
   <a href="/category/business-marketing/"><img alt="arrow" src="https://twimgs.com/gamasutra/images/button_business.gif" width="24px" height="24px"  /></a>
   <div class="leftnav_btn"><a href="/category/business-marketing/">BIZ/MARKETING</a></div>

   <br class="clear">
</div>          <!--end leftnav-->
                  
                    <!-- Beginning Sync AdSlot 3 for Ad unit Gamasutra/ ### size: [[164,59]]  -->
<div id='div-gpt-ad-button1'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-button1');
	}
	);
 </script>
</div>
<!-- End AdSlot 3 -->
            <!-- Beginning Sync AdSlot 4 for Ad unit Gamasutra/ ### size: [[164,59]]  -->
<div id='div-gpt-ad-button2'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-button2');
	}
	);
 </script>
</div>
<!-- End AdSlot 4 -->
            <!-- Beginning Sync AdSlot 5 for Ad unit Gamasutra/ ### size: [[164,409]]  -->
<div id='div-gpt-ad-callout'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-callout');
	}
	);
 </script>
</div>
<!-- End AdSlot 5 -->
            <!-- Beginning Sync AdSlot 9 for Ad unit Gamasutra/ ### size: [[164,177]]  -->
<div id='div-gpt-ad-custom1'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-custom1');
	}
	);
 </script>
</div>
<!-- End AdSlot 9 -->
            <!-- Beginning Sync AdSlot 11 for Ad unit Gamasutra/ ### size: [[164,177]]  -->
<div id='div-gpt-ad-custom3'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-custom3');
	}
	);
 </script>
</div>
<!-- End AdSlot 11 -->
                
        <!-- begin event tickers -->
			              
        <!-- end event tickers -->
	
         <!--begin jobs-->
            <div class="header"><img alt="arrow" src="https://twimgs.com/gamasutra/images/icon_jobs.png" width="22px" height="20px"/><a href="https://jobs.gamasutra.com/">Latest Jobs</a></div>
<div class="leftnav bottom2">
     <a href="https://jobs.gamasutra.com/"><strong>View All</strong></a> &nbsp;&nbsp;&nbsp;
     <a href="https://feeds.feedburner.com/GamasutraJobs"><strong>RSS</strong></a>
     <hr>
     <strong>April 21, 2021</strong>
     <hr>
     <ul>    
            <li>Insomniac Games<br />
              <a href="https://jobs.gamasutra.com/job/narrative-system-designer-burbank-california-34873">Narrative System Designer</a>
        </li>
        <li class="line"></li>
            <li>innogames<br />
              <a href="https://jobs.gamasutra.com/job/senior-game-designer-for-a-new-f2p-mobile-game-feature-design-amp-amp-live-ops-hamburg-34913">Senior Game Designer for a new F2P Mobile Game - Feature Design &amp;amp; Live Ops</a>
        </li>
        <li class="line"></li>
            <li>innogames<br />
              <a href="https://jobs.gamasutra.com/job/-experienced-haxe-developer-ndash-video-game-forge-of-empires-ndash-innogames-hamburg-34962">(Experienced) Haxe Developer &amp;ndash; Video Game: Forge of Empires &amp;ndash; InnoGames</a>
        </li>
        <li class="line"></li>
            <li>Sucker Punch Productions<br />
              <a href="https://jobs.gamasutra.com/job/senior-concept-artist-bellevue-washington-34947">Senior Concept Artist</a>
        </li>
        <li class="line"></li>
            <li>Sucker Punch Productions<br />
              <a href="https://jobs.gamasutra.com/job/combat-designer-bellevue-washington-34946">Combat Designer</a>
        </li>
        <li class="line"></li>
            <li>Sucker Punch Productions<br />
              <a href="https://jobs.gamasutra.com/job/junior-technical-designer-bellevue-washington-34945">Junior Technical Designer</a>
        </li>
        <li class="line"></li>
         </ul>    
</div>
         <!--end jobs-->   
           			
         <!--begin blogs-->
            <div class="header"><img alt="arrow" src="https://twimgs.com/gamasutra/images/icon_blogs.png" width="22px" height="20px"/><a href="/blogs/">Latest Blogs</a></div>
<div class="leftnav bottom2">
    <a href="/blogs/"><strong>View All</strong></a> 
    &nbsp;&nbsp;&nbsp; <a href="/blogs/edit/"><strong>Post</strong></a>
    &nbsp;&nbsp;&nbsp; <a href="/blogs/rss/"><strong>RSS</strong></a>
    <hr>
    <strong>April 21, 2021</strong>
    <hr>   
    <ul>
        
        <li>
            <a href="/blogs/SimonCarless/20210419/380094/When_demos_can_radically_expand_your_games_discoverability.php">When demos can radically expand your game's discoverability</a>
                    </li>
        <li class="line"></li>
        
        <li>
            <a href="/blogs/JavierBarnes/20210419/380065/Predictions_on_Supercells_new_Clash_Games.php">Predictions on Supercell's new Clash Games</a>
                    </li>
        <li class="line"></li>
        
        <li>
            <a href="/blogs/ChelseaBlasko/20210416/379970/One_Year_Into_the_Pandemic	.php">One Year Into the Pandemic	</a>
                    </li>
        <li class="line"></li>
        
        <li>
            <a href="/blogs/WinifredPhillips/20210415/379826/Composer_Interview_Examining_the_Craft_of_Video_Game_Music_Composition.php">Composer Interview: Examining the Craft of Video Game Music Composition</a>
                    </li>
        <li class="line"></li>
        
        <li>
            <a href="/blogs/KyleKukshtel/20210415/379915/Rendered_4_A_New_Reality_for_Epic_and_MLAssisted_Creativity.php">Rendered #4: A New Reality for Epic and ML-Assisted Creativity</a>
                    </li>
        <li class="line"></li>
       
    </ul>
</div>
         <!--end blogs-->
         
         <!--begin press releases-->
            <div class="header"><img alt="arrow" src="https://twimgs.com/gamasutra/images/icon_blogs.png" width="22px" height="20px"/>Press Releases</div>
<div class="leftnav bottom2">
    <strong>April 21, 2021</strong>
	<hr>
	       <a href="/pressreleases_index.php"><strong>Games Press</strong></a>
   <hr>
   <ul>
          
        <li>
            <a href="https://www.gamasutra.com/view/pressreleases/380210/SongPop_3_Now_Available_on_the_App_Store_and_Google_Play.php">SongPop 3  Now Available
on the App Store and...</a>
        </li>
        <li class="line"></li>
          
        <li>
            <a href="https://www.gamasutra.com/view/pressreleases/380211/The_Great_Ace_Attorney_Chronicles_Comes_To_The_West_On_July_27.php">The Great Ace Attorney
Chronicles Comes To
The...</a>
        </li>
        <li class="line"></li>
          
        <li>
            <a href="https://www.gamasutra.com/view/pressreleases/380201/Ocean_Drive_Studio_Announces_First_Title_Lost_Eidolons_For_Classic_TurnBased_RPG_Players.php">Ocean Drive Studio
Announces First Title,
Lost...</a>
        </li>
        <li class="line"></li>
          
        <li>
            <a href="https://www.gamasutra.com/view/pressreleases/380202/Online_LooterShooter_Vigor_Receives_New_Season_8_Trappers.php">Online Looter-Shooter
Vigor Receives New Season
8:...</a>
        </li>
        <li class="line"></li>
          
        <li>
            <a href="https://www.gamasutra.com/view/pressreleases/380203/Were_going_to_rip_out_their_living_goddamned_guts_and_use_them_to_grease_the_treads_of_our_tanks.php">“We're going to rip
out their living
goddamned...</a>
        </li>
        <li class="line"></li>
         </ul>
   <a href="/pressreleases_index.php"><strong>View All</strong></a> 
   &nbsp;&nbsp;&nbsp; <a href="/pressreleases/rss/"><strong>RSS</strong></a>
</div>         <!--end press releases-->
                         
         <!--begin calendar-->
            <!--

<div class="header"><img alt="arrow" src="https://twimgs.com/gamasutra/images/icon_calendar.png" width="22px" height="20px"/><a href="http://www.gamasutra.com/calendar/calendar.php">Calendar</a></div>
<div class="leftnav bottom2">
    <a href="http://www.gamasutra.com/calendar/calendar.php"><strong>View All</strong></a> &nbsp;&nbsp;&nbsp; <a href="http://www.gamasutra.com/calendar/calendar_submit.php"><strong>Submit Event</strong></a>
    <hr>
    <ul>
        
    </ul>
</div>

-->         <!--end calendar-->
                         
         <!--begin about-->
            <div class="header"><img alt="arrow" src="https://twimgs.com/gamasutra/images/icon_about.png" width="22px" height="20px"/><a href="/contactus">About</a></div>
<div class="leftnav bottom2">
    <ul>
            <li><strong>Editor-In-Chief: </strong><br /><a href="/cdn-cgi/l/email-protection#b4dfd3c6d5d2c0f4d3d5d9d5c7c1c0c6d59ad7dbd9">Kris Graft</a></li>
            <li class="line"></li>
            
            <li><strong>News Editor: </strong><br /> <a href="/cdn-cgi/l/email-protection#10717c796363713e7d73717c7f7f7e5065727d3e737f7d">Alissa McAloon</a></li>
            <li class="line"></li>
            
            <li><strong>Contributors: </strong><br />
				Chris Kerr<br />
				Bryant Francis<br />
				Katherine Cross<br />
			</li>	
            <!--<li><strong>Advertising: </strong><br /><a href="mailto:sales@gamasutra.com?subject=Request%20Info:%20Gamasutra">sales@gamasutra.com</a></li>-->
    </ul>
    <hr>
    <div class="center"><a href="/contactus">Contact Gamasutra</a></div>
    <hr>
    <div class="center"><a href="/cdn-cgi/l/email-protection#1d6e686d6d726f695d7a7c707c6e68696f7c337e7270">Report a Problem</a></div>
    <hr>
    <div class="center"><a href="/cdn-cgi/l/email-protection#452b203236052224282436303137246b262a28">Submit News</a></div>
    <hr>
    <div class="center"><a href="/static2/comment_guidelines.html">Comment Guidelines</a></div>
    <hr>
    <div class="center"><a href="/static2/blogsubmissions.html">Blogging Guidelines</a></div>
    <hr>
    <div class="center"><a href="/static2/howwework.html">How We Work</a></div>
	<!--<hr>
	<div class="center"><a href="/advertise">Advertise with Gamasutra</a></div>-->
	<hr>
    <div class="center"><a href="https://reg.gdconf.com/gama-media-kit">Download Media Kit</a></div>
</div>

<div class="bottom2">
    <a href="/advertise">
        <img src="https://twimgs.com/gamasutra/images/AdwGama_177x60_button_v1.jpg" alt="Sponsor" border="0" class="whiteTop"  width="177px" height="60px"/>
    </a>
</div>
             <!--end about-->
         
         <!--begin network-->
            <div class="header"><img alt="arrow" src="https://twimgs.com/gamasutra/images/icon_about.png" width="22px" height="20px"/><a href="#">Gama Network</a></div>
<div class="leftnav_network bottom2">
    If you enjoy reading this site, you might also want to check out these UBM Tech sites:
    <hr>
    <a href="https://www.gamecareerguide.com"><!-- img src="http://www.indiegames.com/blog/gcgmini.jpg" align="left" hspace="2"/ --></a> 
    <div class="leftnav_btn"><a href="https://www.gamecareerguide.com">Game Career Guide</a></div>
    <hr>
    <a href="https://www.indiegames.com/blog"><!-- img src="http://www.indiegames.com/blog/indiemini.jpg" align="left" hspace="2"/ --></a>
    <div class="leftnav_btn"><a href="https://www.indiegames.com/blog">Indie Games</a></div>
    <br class="clear">
</div>         <!--end network-->
         
         <!--begin store-->
                     <!--end store-->
         
                
    </div><!--end leftcol-->
  </div>
</div> 
</div>  	<style>.content_box_middle pre {
		overflow-x:auto;
	}
	.item_title{
		    margin-top: 0px !important;
			margin-bottom: 0px !important;
	}
	</style>
<div class="span-16 last">
    <div class="content_box_middle">
        <!-- InstanceBeginEditable name="BodyContent" --> 
        <div class="header_large">
            <span class="left"><img alt="arrow" src="https://twimgs.com/gamasutra/images/icon_blogs.png"/><a href="/blogs/">Blogs</a></span>
        </div>
        <div class="page_item"> 
                        <div class="clear">&nbsp;</div>
            <h1 class="item_title">Alternate Reality Game puzzle design</h1>
            <div>
                <span class="newsAuth">by <a href="/blogs/author/AdamFoster/939620/">Adam Foster</a> on 06/17/13 12:00:00 am 
                    &nbsp; <img valign="bottom" border="0" src="https://twimgs.com/gamasutra/images/expertIcon_gamaBlog.gif" alt="Expert Blogs" />                    &nbsp; <img valign="bottom" border="0" src="https://twimgs.com/gamasutra/images/featuredIcon_gamaBlog.gif" alt="Featured Blogs" />                                        <br />
                </span>
            </div>
            <div>
                <br>
                                    <span class="comment_text">
                                                    <a href="#comments">7 comments</a>
                                            </span>
                    <a name="twitter_share" type="button" href="http://twitter.com?status=RT @gamasutra: Alternate Reality Game puzzle design http://www.gamasutra.com/blogs/AdamFoster/20130617/194321/" target="_blank"><img src="https://twimgs.com/gamasutra/images/twitter.gif" alt="Share on Twitter" border="0" height="20"/></a>
                    <iframe src="https://www.facebook.com/plugins/share_button.php?href=https://www.gamasutra.com/blogs/AdamFoster/20130617/194321/&layout=button&size=large&mobile_iframe=true&width=72&height=28&appId" width="72" height="28" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowTransparency="true"></iframe>

                    <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript" src="https://apis.google.com/js/plusone.js"></script>
                    <g:plusone size="medium" count="false"></g:plusone>
					<span id="edit_post_link"></span>&nbsp;&nbsp;
					<a href="/blogs/rss/"><img src="https://twimgs.com/gamasutra/images/icon_rss.gif" width="15" height="15" border="0" alt="RSS" /></a>
                            </div>
            <hr>
            <div class="item_body mobile_image_transform">       
                <strong><i><small>
                    The following blog post, unless otherwise noted, was written by a member of Gamasutra&#146;s community.<br />
					The thoughts and opinions expressed are those of the writer and not Gamasutra or its parent company.                </small></i></strong>
                <hr>
                <div class="clear">&nbsp;</div>
                <p><strong><em>This article is being highlighted as one of Gamasutra&#39;s top stories of 2013.</em></strong></p>

<h2>Introduction</h2>

<p>A &#39;game&#39; can be built in any sufficiently complex system. It does not need to limit itself to traditionally game-specific platforms, be they hardware or software. It&#39;s quite possible to break outside the usual boundaries and use the real world itself as the setting for your fictional game world - reusing existing physical, logical and societal rules and constraints to implement your game.</p>

<p>This is the <a href="https://en.wikipedia.org/wiki/Alternate_reality_game">Alternate Reality Game</a>.</p>

<p>But, in a world of near-infinite complexity and endless interlocking systems, how do you tell your players what&#39;s part of the game and what&#39;s an irrelevant part of reality? How can you design puzzles where literally anything could be interpreted as a clue?</p>

<p>In this article, I&#39;ll be describing the puzzle design behind Valve&#39;s <em>Portal 2</em> announcement, in which players across the internet collaborated in decoding mysterious audio broadcasts, brute-forced an MD5 hash then redistributed never-before-seen imagery from <em><a href="http://store.steampowered.com/app/620/">Portal 2</a></em>, obtained from an incredibly slow, 1980s-style bulletin board system. A 21st-century treasure hunt, built using real-world systems and knowledge.<br />
<br />
<img alt="Portal 2 robots, ANSI-style!" height="496" src="https://www.gamasutra.com/db_area/images/blog/194321/arg-robots.png" style="display: block; margin-left: auto; margin-right: auto;" width="608" /></p>

<p>A relatively small-scale, incredibly low-budget project. Estimated time to &#39;solve&#39; the intial puzzles: seven hours.</p>

<p>Actual time to solve: seven hours and sixteen minutes. <em>This wasn&#39;t an accident.</em></p>

<h2>Background</h2>

<p>I&#39;ve always been obsessed with the literary concept of the &#39;<a href="https://en.wikipedia.org/wiki/False_document">false document</a>&#39; - fictional worlds extended through apparently real maps, documents, letters and systems. Various creative writing exercises even from primary school included detailed maps and plans for imaginary locations and buildings, artificial letters and newspapers - carefully crumpled, torn and artificially aged with tea and flame.</p>

<p>Extending this kind of behaviour to the computer world made more than a little sense. My level design career started more as fulfilling a desire to create new worlds than from a want to play more computer games - soon releasing well-received maps for <em>Doom</em> 2 without having ever finished playing through either <em>Doom </em>1 or 2.</p>

<p>The website for <em><a href="https://hylobatidae.org/minerva/">MINERVA</a></em>, my <em>Half-Life 2</em> game mod, ended up being effectively in-fiction, with the character Minerva giving motivations, cryptic archive materials and disguised download links in the form of a broken scientific report - relaying her findings in this fictional world.</p>

<p>Along the way, I inadvertently acquired a job at Valve. How should I announce this to the fans?</p>

<p><a href="https://hylobatidae.org/minerva/blogsheep.php?action=articleinfo&id=75">Quite obviously</a>, it took the simulated form of a post-apocalyptic numbers station, seemingly broadcasting numbers (in Polish!) which encoded a secret message. EBCDIC text, GPS coordinates for the Valve office - those fans figured it out pretty quickly. I definitely learned not to underestimate their sleuthing capabilities.</p>

<h2>Portal 2 announcement</h2>

<p>Fast-forward a few years to being happily installed at Valve. We were due to announce <em>Portal 2</em> to the public, and had lined up a mainstream marketing push through <a href="http://www.gameinformer.com/mag/portal2.aspx">Game Informer magazine</a>. Excellent for the wider market, but what about the fans who&#39;d lived and breathed the original Portal?<br />
<br />
We&#39;d been thinking about making some completely unexpected changes to <em>Portal</em> - adding, unannounced, some mysterious new content which <em>Portal</em> fans would enthusiastically decipher, thereby revealing the upcoming <em>Portal 2</em> for themselves before anyone else. Steam made such updates incredibly simple - freely pushing out new content to everyone who owned the original game on Steam. To do something similar on the consoles would have involved a nightmarish level of bureaucracy.<br />
<br />
Soon enough, the <em>Portal 2</em> announcement ARG was born, hereafter known simply as the &#39;Portal ARG&#39;. It took the form of updating the original game to include radios scattered throughout the game&#39;s test chambers - pick a radio up and carry it through the test chamber and a strange new signal would begin to fade in - take it to the right location and a static-free signal would be picked up. Morse code beeping, peculiar squeaky-beeping suggesting other encoded information. Finding the radios was one puzzle, finding the correct locations for the new signals was another puzzle - one which rewarded players with a Steam achievement when they located them all.</p>

<p style="text-align: center;"><img alt="Decoding in-game SSTV audio" height="400" src="https://www.gamasutra.com/db_area/images/blog/194321/arg-sstv.jpg" width="640" /> <br />
<em>YouTube: <a href="http://www.youtube.com/watch?v=DlIvnc-AZJQ">Portal - secret SSTV radio transmissions</a></em></p>

<p>(Inevitably, the more technical-minded players immediately reached into the game&#39;s data files and extracted the responsible audio files for decoding.)<br />
<br />
<img alt="SSTV image with fragment of MD5 hash" height="240" src="https://www.gamasutra.com/db_area/images/blog/194321/arg-sstv-md5-fragment.png" style="display: block; margin-left: auto; margin-right: auto;" width="320" /></p>

<p>First the morse code was decoded, then the squeaky-beeping was discovered to be slow-scan television - containing mysterious images containing letters and numbers, seemingly taken from bits of office and scientific equipment. These in turn were pieced together to provide an MD5 hash, which with clues obtained from other SSTV images and the morse code, was brute-forced to reveal a telephone number. Which, when called, provided a 1980s-style BBS, looping through plot fragments, ANSI-art imagery and (most importantly) ANSI-art conversions of screenshots and concept art from Portal 2.</p>

<p style="text-align: center;"><img alt="ANSI art from Aperture BBS" height="533" src="https://www.gamasutra.com/db_area/images/blog/194321/arg-bbs-art.gif" width="639" /><br />
<br />
<em>YouTube: <a href="https://www.youtube.com/watch?v=SpzV7Hy_zVE">Valve BBS Login</a></em></p>

<p>Yes, <a href="http://kotaku.com/5484157/valves-portal-puzzle-so-far-the-files-recovered-from-aperture-science">the first the world ever saw</a> of this eagerly anticipated game was filtered through a 2400bps US Robotics modem from 1987, connected to an old PC in my kitchen.</p>

<p>But how did players fight their way through such complexity (for instance, reversing an MD5 hash is supposed to be impossible) - and more importantly, how did we keep everyone, from bystander to elite hacker, engaged?</p>

<p>There&#39;s an <a href="http://combineoverwiki.net/wiki/Portal_ARG">excellent overview of the Portal ARG</a> at the fan-operated Combine Overwiki if you&#39;re interested in the players&#39; experiences of this first Portal ARG, as well as the <a href="http://forums.steampowered.com/forums/showthread.php?t=1170872">huge forum threads it spawned</a> - but we have the advantage of being able to delve behind the scenes...</p>

<h2>Fictional rationale</h2>

<p>In its later stages, the Aperture Laboratories facility became a huge, self-assembling robotic organism, endlessly rearranging itself in pursuit of its twisted idea of &#39;science&#39;. Perhaps someone (or something) was trying to get a message out without being noticed by GLaDOS, Aperture&#39;s central artificial intelligence?</p>

<p>With that in mind, we looked into real-world systems for encoding information - to relay that message over a subverted communications infrastructure. Radios intended for broadcasting the scientifically-proven-to-be-relaxing smooth jazz to test subjects would be co-opted into picking up additional signals leaking from hacked computer hardware. These revealing clues would then lead to a forgotten Aperture data backup apparatus, ready to release its secret data in a (distinctly slow) deluge when another human eventually discovered it. A system set up to transmit a message about Aperture, encoded and concealed from Aperture itself.</p>

<p>The only public announcement of the update was a vague description - "changed radio transmission frequency to comply with federal and state spectrum management regulations". Curious players of Portal soon uncovered the beginnings of this riddle, then found it wrapped in a mystery inside an enigma, each level deepening in complexity. A tiny crack in the world they knew, opening up to reveal something else entirely. In opening the path to that new world, the ending of Portal itself would be altered to better explain the beginning of the forthcoming game.</p>

<p>... and now, the article:</p>

<p><strong>How to build fictionally appropriate ARG puzzles that people have fun solving, and <em>which people can solve</em>.</strong></p>

<h2>How to build clues and solutions</h2>

<p>Reusing real-world systems for encoding data is good. Firstly, it&#39;s educational! Secondly, minds far larger than your own have spent far longer than you have in creating resilient, unambiguous systems for encoding that data - and, if chosen carefully, the system will obviously contain information even when not decoded. Steganography isn&#39;t necessarily the aim - at some stages, players must notice information is there to be able to decode it.</p>

<p>When presented with that encoded information, someone will either recognise the system, or through research identify what it is. A real-world system responds to research rather than guesswork - Wikipedia is your best friend. (An example: I knew very little about SSTV beforehand - I got remarkably proficient in knowing of its quirks and features surprisingly quickly.)</p>

<p>It&#39;s important to remember that comparatively few people will be directly involved with solving the puzzles themselves. Make sure there&#39;s plenty of stuff for people less invested in the arcane details of your world - the Portal ARG had the meta-game involved with locating the radios and the signal locations, rewarding players with additional gameplay and an achievement even when the truly hardcore ARG enthusiasts had long since ripped the underlying audio files from the game and decoded them directly.</p>

<p>I feel the most important aspect of a puzzle in an ARG is that a correct solution must be <em>obviously</em> correct - any leaps of faith must immediately succeed. A very low percentage of people will solve any one puzzle; with a chained puzzle, you need to confirm that each stage is solved so that people can work on the next. Otherwise, a low percentage of a low percentage will have a chance of solving that next stage...</p>

<p>Design particular bottlenecks which gate entrance to the next stages. Smaller puzzles can provide clues for these - an example from the Portal ARG would be the morse code and SSTV as &#39;quick&#39; puzzles, providing clues and data for the MD5 hash - the ultimate leap of faith that perhaps just one player will take. While not a perfect analogy, think along the lines of <a href="https://en.wikipedia.org/wiki/Rate-determining_step">rate-determining steps</a> where the time taken for minor steps is insignificant compared with that taken for the most difficult, the latter controlling the entire rate of the reaction.</p>

<p>(I seriously did have the <a href="https://en.wikipedia.org/wiki/Proton–proton_chain_reaction">proton-proton chain reaction</a> ocurring at the centre of the Sun in mind when designing the Portal ARG&#39;s puzzles - the brute-forcing of the MD5 hash being the deuterium-producing event that everything depends upon. Slow, but ultimately essential.)<br />
<br />
You can also add fixed gates to slow things down, preventing the game from exhausting itself too soon and giving players a chance to digest the materials they have uncovered. After the initial burst of puzzling, the Portal ARG had a number of additional stages we manually unlocked, such as the updated ending to Portal, the additional BBS login and so on. Even smaller things would change - I&#39;d frequently add new items to the BBS when I&#39;d verified that previous ones had been successfully received by everyone, providing additional fuel for speculation and giving another continued reason for players to be involved with the game.  </p>

<p>You should expect any and every piece of text you provide to be plugged straight into Google. The morse code containing the mysterious string &#39;9e107d9d372bb6826bd81d3542a419d6&#39;? Stick that in a search engine, find it&#39;s the MD5 hash for &#39;The quick brown fox jumps over the lazy dog&#39;. Therefore, MD5 hashes are important!</p>

<h2>Examples of good encodings</h2>

<p>Part of the fun in decoding a secret message is in seeing structured information emerge from something incomprehensible. A little like developing a photo, with an image emerging from nowhere - there&#39;s a curious satisfaction in extracting data from something that already existed.</p>

<p>For the Portal ARG, it was decided that the very first radio that players would find would be looping through morse code - audio instantly recognisable as containing information. Other morse code radios would be scattered through the game&#39;s test chambers to reinforce the concept of them carrying information, but what else?</p>

<p>In trawling Wikipedia for information on the <a href="https://en.wikipedia.org/wiki/Kansas_City_standard">Kansas City standard</a>, used by computers of the 1970s and 80s to save data on to audio cassettes, I came across <a href="https://en.wikipedia.org/wiki/SSTV">Slow-Scan Television</a>, or SSTV - used by ham radio enthusiasts for relaying imagery over low-bandwidth radio links. This quasi-analogue standard had the interesting properties of <em>sounding</em> mysterious, and of <em>looking</em> interestingly distorted when decoded. Analogue, noisy, atmospheric - this was perfect for encoding near-broken messages intruding in from the unknown. I ended up going with the Robot-36 standard, capable of relaying a reasonable quality colour image in a mere 36 seconds - and one of the sound engineers had great fun mangling the audio to make it both <em>sound</em> and <em>look</em> particularly distorted. (Great care was taken to avoid the information-rich parts of the images.)</p>

<p>A couple of permutations on audio encoding systems can be summarised as follows:</p>

<ul>
	<li><strong>Morse code, SSTV</strong>

	<ul>
		<li>The former is easily recognised, the latter is unambiguously decoded. Even if the results are mysterious, it&#39;s obvious when they&#39;ve been decoded correctly. Much of the entertainment from an ARG is in speculating what the returned information <em>means</em> - the near-impenetrable, distorted SSTV images and hazy, artifact-laden ANSI-art screenshots more than helped contribute to the other-worldly nature of this apparently illicit data.</li>
		<li>SSTV absolutely wins the interesting-to-decode prize - with the Portal ARG, there were many YouTube videos showing people running the audio through various free <a href="http://users.belgacom.net/hamradio/rxsstv.htm">decoding software</a>, with commenters responding with amazement.</li>
		<li>Other audio encodings are available!</li>
	</ul>
	</li>
</ul>

<p>What if you need to relay some piece of information which must be given to players in a complete, error-free form? To use the telephone number for the Aperture BBS as an example - if players were to get the wrong number, either through an incorrect transcription or through guessing at missing digits, an unrelated bystander might end up severely annoyed by the resulting torrent of unsolicited calls.</p>

<p>Potential error-free encodings follow - but by no means an exhaustive list:</p>

<ul>
	<li><strong><a href="https://en.wikipedia.org/wiki/MD5">MD5</a> and other <a href="https://en.wikipedia.org/wiki/Cryptographic_hash_function">cryptographic hashes</a>.</strong>

	<ul>
		<li>Not so much an encoding system as a verification that you have the correct data. <em>Extremely</em> low probability that you&#39;ve got the wrong answer, but players will need to brute-force it with a carefully specified format.</li>
		<li>For the Portal ARG, two SSTV images carefully laid out the expected format for the phone number: "(###) ###-####". Players obtained hexadecimal digits for the MD5 hash from numbered SSTV images, assembling them into"9459c6cac8c203b8128b7cc63068d4fd".</li>
		<li>When &#39;solved&#39;, a fully-formed answer pops out as if by magic.</li>
		<li>I wrote a script in PHP to both test the plausibility of brute-forcing the Portal ARG&#39;s MD5 hash and check for any (incredibly unlikely) collisions - it cycled through billions of potential phone numbers before magically revealing the phone number. Which, admittedly, I already knew, but it was a good verification that everything worked!</li>
		<li>It&#39;s good insurance against players having a mangled copy of the hash - it&#39;s unlikely to spit out someone else&#39;s phone number by mistake.</li>
		<li>Variations on the theme could include password-protected archive files, /etc/shadow password files and other faintly-dubious brute-force cracks which could fit with a hacker-themed ARG. Be careful that players don&#39;t go on to hack the <em>real</em> systems supporting your game...</li>
	</ul>
	</li>
	<li><strong>Barcodes, QR codes etc.</strong>
	<ul>
		<li>These frequently contain built-in checksums - as with MD5 hashes, these provide resilience against players getting the wrong result, but are perhaps too easy to decode?</li>
		<li>Other visual encodings are, of course, available!</li>
	</ul>
	</li>
	<li><strong>Obsolete software and file formats</strong>
	<ul>
		<li>If from some easily-emulated system, people will get it running <em>very</em> quickly.</li>
		<li>On MINERVA, I <a href="https://hylobatidae.org/minerva/blogsheep.php?action=articleinfo&id=50">released some screenshots</a> on a compressed floppy disk image for an Atari ST - containing imagery in a distinctly obscure &#39;PhotoChrome&#39; format. Software not included, of course - but people got the screenshots decoded in a matter of hours. Nerds are scary.</li>
		<li>The Portal 2 BBS provided a quirkily antiquated GWBasic image-display program - requiring a prehistoric DOS system to run. (Of course, I&#39;d checked that it was easy to get running in an unmodified DOSBox installation...)</li>
		<li>People got <em>that</em> one running within minutes.</li>
	</ul>
	</li>
	<li><strong>Particular editions of books, scientific papers etc.</strong>
	<ul>
		<li>Use check-words for checksum purposes?</li>
		<li>For example, give positions for two words in each book, one always being the same across all books. If one book gives a different word, then players will notice the discrepancy.</li>
		<li>Human brains are very good at spotting patterns - which is both a blessing and a curse. They&#39;ll even spot patterns where none exist.</li>
	</ul>
	</li>
</ul>

<p>Importantly, be mysterious in your puzzles - but not ambiguous with the answers. Vigorously test-drive all clues and data - if there&#39;s any text, put it into search engines to see what comes out, and if necessary adjust the text to give better results. If you&#39;ve got an image, put it into reverse image searches to see what comes up. Test the most likely lines of investigation that players will take, and design your puzzles around them.</p>

<h2>Examples of bad encodings</h2>

<p>Anagrams, arbitrary encodings and similar which don&#39;t lead to an undeniably correct answer. If there&#39;s some doubt or personal opinion involved in decoding, beware. You don&#39;t want people trying to solve red herrings provided by incorrect solutions - or worse, being led to real-world systems or locations which <em>aren&#39;t</em> part of the game.</p>

<p>Encoded information should be recognisable as such, even if the actual encoding is a mystery - or perhaps be hidden in plain sight, with a clear clue to its existence being brought up later. Imagine one puzzle revealing that the clues for the next puzzle were there all along...</p>

<p>Search results will change, and troll sites immediately crop up with any vaguely successful ARG. You need an incontrovertible chain of in-game evidence to prove new information is also in-game.</p>

<ul>
	<li>&#39;Interesting-looking YouTube video I found&#39; - out of game.</li>
	<li>&#39;Unambiguous link to YouTube video&#39; - in-game.</li>
	<li>&#39;YouTube video on official company channel&#39; - potentially in-game!</li>
</ul>

<p>You need to authenticate what&#39;s in-game and what isn&#39;t. Official company pronouncements can be fair game for players attempting to find hidden meanings - whether those meanings are there or not. Be aware that players will attempt to follow every possible trail of information, however tenuous or implausible.</p>

<p>Having said that, there&#39;s still plenty of opportunity to add deliberately mysterious content. The Portal ARG&#39;s SSTV images included quite a few &#39;padding&#39; images of electronics, scientific equipment and robotic hardware - amongst the screenshots, plot fragments and concept art, the BBS itself would output various inscrutable scientific diagrams specially drawn by an artist at Valve. Rampant speculation on the forums was the inevitable result - speculation anyone and everyone would participate in.</p>

<p>Think of an ARG as both an in-depth puzzle and a participatory work of fiction. It&#39;s not about just the game itself, it&#39;s what the community does with it.<br />
<br />
(Was the material found on the BBS enough of a reward for players? On its own, perhaps not, but combined with the speculation, enjoyment and exploration everyone got from the game, definitely yes. It&#39;s not just the destination but the journey that counts.) </p>

<h2>Real-world considerations</h2>

<p>Something that looks like &#39;specialist knowledge&#39; may not be - but do ensure things are at a level where a determined participant can get to from scratch within half an hour or so. Try getting to a similar position with obvious web search keywords and other clues provided by your puzzles, adjusting them as necessary.</p>

<p>Part of the fun of an ARG&#39;s real-world aspects are in what it adds to the fiction - a sense of the unreal colliding with the real. But don&#39;t use an expert in any particular domain of knowledge to design complete puzzles - you want things to <em>look</em> super-advanced rather than <em>be</em> super-advanced. (Not everyone is <a href="http://bellard.org/dvbt/">Fabrice Bellard</a>...)</p>

<p>If you&#39;re learning about new systems yourself, you&#39;ll have a better understanding as to what kind of clues you&#39;ll need to provide to help beginners.</p>

<p>If important information is relayed, make sure it can be retrieved by multiple participants. You don&#39;t necessarily need it to be retrievable by <em>every</em> participant - we spent a fair amount of time thinking about how to make collaboration between groups a requirement, with the game sharing audio files with some but not all players. Unfortunately the limited timeframe meant we couldn&#39;t implement some of the Steam-related ideas we had for discouraging players from keeping data for themselves.</p>

<ul>
	<li><strong>Worst-case scenario:</strong> someone activates a particular special system and fails to capture the information it provides.</li>
	<li><strong>Second worst-case:</strong> that someone keeps the information for a small group which then gains an unfair advantage in subsequent stages of the game.</li>
	<li><strong>Third worst-case:</strong> someone makes up information and claims they received it from the game, and <em>no one else can check</em>.</li>
</ul>

<p>One solution to relaying information could involve &#39;unlocking&#39; an easily-accessible virtual gate, for example on a website or inside a computer game. The Portal ARG had the game updating itself with an <a href="http://www.youtube.com/watch?v=bMrfOZg0dtk">extended ending</a> once players had accessed and retrieved data from the BBS, with the BBS providing vague hints as to what was coming next. (We had planned more direct interaction through the BBS, with players entering Steam usernames for explicit recognition of their actions, but time constraints meant we were left with a more passive BBS simply outputting data to anyone who connected before we manually flipped a switch for the next stage.)</p>

<p>Another method could involve a difficult-to-access system or location that enough different people can get to, for example the BBS itself. Clues in the real-world could work in a similar way - only one player is needed to go there, but there would be nothing stopping more than one from arriving. But beware of stampedes and flash crowds...</p>

<p>Could you obtain some sort of recording of the person unlocking the next stage for everyone? Handy! Serious nerd-cred when the feat is announced to all the players.</p>

<p>Be keenly aware that the game intersects with reality - be absolutely unambiguous where appropriate. Going back to the MD5 hash of a phone number as an example, despite there being a <em>very</em> low likelihood of a false positive turning up, I checked every single US phone number for collisions, <em>just in case</em>. As mentioned earlier, for players to get a bystander&#39;s phone number by accident would be a Bad Thing.</p>

<h2>Accidental false clues and connections</h2>

<p>When players connected to the Aperture BBS, it would loop through &#39;data files&#39; with numerical identifiers. One person was <em>convinced</em> these numbers contained vital information, so spent a very long time trying to decipher them - turning them into IP addresses then geolocating and portscanning all the possibilities in order to find the &#39;right&#39; next system. However, the numbers were actually from PHP&#39;s rand() function, seeded by each data file&#39;s length for consistency purposes.</p>

<p>Effectively no information content, but enough to lead someone down a potentially dangerous path.</p>

<p>Another persistent but more entertaining false clue was present in the radio-dissolving sounds added to Portal - carry a radio into an equipment-destroying &#39;fizzler&#39; field, and its removal would be accompanied by a harsh, grating, electro-mechanical sound. People were <em>convinced</em> they could hear voices - claiming Alyx and Kleiner from Half-Life 2 were saying Important Things, or that there was a Combine Citadel present in a spectrogram.</p>

<p>Actually, the sounds <em>did</em> contain voices - but not from the cast of Half-Life 2. It was Left 4 Dead&#39;s <em>Midnight Riders</em> instead!</p>

<p>Another, accidental false clue was in the BBS-provided GWBasic image-viewing program. The source code included an (authentically ancient) copyright date and room number for a Doug Rattmann in the comments at the top, added for purposes of verisimilitude. Of course, many people assumed the room number was for a phone extension at the real-world Valve office, so tried calling it - resulting in a very confused person in Support!</p>

<p>Be careful with numbers. Someone will <em>certainly</em> attempt to extract meaning from them, whether you intended it or not.</p>

<h2>Reality, or game?</h2>

<p>You need to define boundaries as to where the game ends and reality begins. In the Portal ARG, information considered &#39;in-game&#39; was present in the original Portal, obtained from the Aperture BBS or in official Valve press releases and the like - never from arbitrary locations on the internet. Troll sites proliferated, confusing many - people less involved in low-level details won&#39;t appreciate existing logical connections, so a plausible-looking troll can get stuck amongst the genuine content.</p>

<p>Speaking of troll content - a false clue can emerge seemingly from nowhere, then persist for far longer than would seem possible, its own longevity somehow being proof of its veracity. With the Portal ARG, the phrase &#39;look beneath the elephant green&#39; sprang up, allegedly arriving in an email from Valve&#39;s Robin Walker, then stuck around forever.</p>

<p>A blurring of the boundary between game and reality occurred due to an implementation quirk of the BBS. Partly due to the short notice and the confusion involved with a Valve office move, it was easiest for me to get an analogue phone line at my then apartment - plumbing in a 1980s-modem-compatible phone line to the new office being considered more than a little awkward. Upon setting up this new phone line, I opted to be ex-directory, hoping for a little extra privacy and not realising the impact the game would have.</p>

<p>Of course, when they obtained the number, people plugged it into various online services - which, refusing to admit defeat when confronted with an unlisted number, gave the address as being the geographic centre of the nearby Kirkland. So obviously, someone went to that location and had a look round, posting back details to the Steam forums.<br />
<br />
(I had just left the office to go home, so wasn&#39;t immediately able to tell other Valve persons that the address most definitely <em>wasn&#39;t</em> mine - they got quite worried for me!)</p>

<p>Luckily, it was a public place and he didn&#39;t get in any kind of trouble, but it&#39;s worth considering the accidental effects such real-world details can have.<br />
<br />
Another person found what he thought was Valve&#39;s current office address, and turned up at the front door hoping to track down that elusive phone line. But Valve had, just days earlier, moved to a new location - presenting him with nothing but a huge, empty void. Mind blown, he reported back to the internet that the entire company had disappeared, just like that...</p>

<p>A later attempt at extracting a location from the phone number involved some dodgy paid-for service - that person got an &#39;ADAM FOSTER&#39; but fortunately no address. He really didn&#39;t seem to understand the game / reality boundary, despite warnings from other users on the Steam forums - it got more than a little creepy.<br />
<br />
Someone else managed to find a personal phone number for Valve&#39;s receptionist. Fortunately for everyone, players decreed that harrassing her for information would be deeply inappropriate - they did the right thing and went no further.<br />
<br />
People are fundamentally good, they can just get a little over-enthusiastic at time. </p>

<h2>Treasure hunt versus ongoing interaction</h2>

<p>The Portal ARG was intended mainly as a treasure hunt, initially with a fixed chain of clues and puzzles. This worked well with the overall aim - letting fans of Portal know about an impending sequel before anyone else - but another, lomger-lasting approach is for the game to more directly interact with players as the &#39;story&#39; progresses. Possible examples we could have used might include a live &#39;chat&#39; with an &#39;AI&#39; on the Aperture BBS - adjusting the game according to their input. (Players feel super-special when included in the game like this.)</p>

<p>An ongoing ARG suggests a much larger scale. Examples would include <em><a href="https://en.wikipedia.org/wiki/The_Beast_(game)">The Beast</a></em>, which promoted the film <em>A.I.</em>, or <em><a href="https://en.wikipedia.org/wiki/I_Love_Bees">I Love Bees</a></em>, promoting <em>Halo 2</em> - the latter ARG involving GPS coordinates of payphones across the USA, with phone calls to players at specific times. Seriously impressive work, but perhaps with budgets <em>slightly</em> higher than the Portal ARG&#39;s $100!</p>

<p>More direct interaction with players can mean deliberate emphasis of clues that have been missed, or perhaps dismissal of false clues and trolls.</p>

<p>(I wasn&#39;t involved in the Portal 2 launch ARG, being extremely busy finishing the game itself, but I hope this article proves useful to many people thinking about some of the low-level design ideals involved in implementing an ARG!)</p>

<h2>Fun coincidences</h2>

<p>When you apply perhaps tens of thousands of people to figuring out a problem of your making, they&#39;ll come up with solutions you didn&#39;t know existed - weird coincidences that must have been better than intentional.</p>

<p>The underlying audio files for the radios added to Portal were named dinosaur[n].wav - the &#39;dinosaur&#39; an inside joke referring to the antiquated technology involved. By pure coincidence, there were twenty-six of them. Also coincidentally, the voice actor for Doctor Kleiner in Valve&#39;s <em>Half-Life</em> series, Harry S. Robins, wrote a book called ... <em>Dinosaur Alphabet</em>.</p>

<p><img alt="Dinosaur Alphabet" height="240" src="https://www.gamasutra.com/db_area/images/blog/194321/arg-dinosaur-alphabet.jpg" style="display: block; margin-left: auto; margin-right: auto;" width="264" /></p>

<p>Twenty-six dinosaurs, surely implying an alphabet? Definitely not an intentional coincidence, but pretty cool!</p>

<p><img alt="Super-noisy SSTV image" height="240" src="https://www.gamasutra.com/db_area/images/blog/194321/arg-sstv-robot.png" style="display: block; margin-left: auto; margin-right: auto;" width="320" /></p>

<div>
<p>One &#39;flavour&#39; SSTV image (with no clues, just padding supporting the fiction) was a noise, abstract picture of circuitry, obtained from a photo I&#39;d recently taken at the MIT Museum in Boston. Players (manually) tracked down a <a href="http://www.flickr.com/photos/twosevenoneonenineeightthreesevenatenzerosix/4317492964/in/set-72157623315938604">clear version on my Flickr account</a>. Interesting enough, but...</p>

<p>... the robot was &#39;HERBERT&#39;, designed to pick up empty drinks cans from the floor.</p>

<p><br />
<img alt="HERBERT robot" height="300" src="https://www.gamasutra.com/db_area/images/blog/194321/arg-herbert-robot.jpg" style="display: block; margin-left: auto; margin-right: auto;" width="456" /> </p>

<p>At the beginning of Valve&#39;s <em>Half-Life 2</em>, there&#39;s a sequence in which ... the player is made to pick up an empty drinks can from the floor.</p>

<p><img alt="Pick up that can!" height="660" src="https://www.gamasutra.com/db_area/images/blog/194321/arg-combine.jpg" style="display: block; margin-left: auto; margin-right: auto;" width="600" /></p>

<p>Pure coincidence. Be prepared for it, and design your puzzles to cope with it.</p>
</div>

            </div>   
                                                <hr>
                    <div class="hide-phone">
                        <h3>Related Jobs</h3>
                                                   <div class="stories_item">
                                <div class="thumb"><a href="https://jobs.gamasutra.com/job/narrative-system-designer-burbank-california-34873"><img src="https://d1506sp6x4e9z7.cloudfront.net/gamasutra/uploads/944557.jpg" alt="Insomniac Games" width="120"></a></div>
                                <div class="title">
                                    <strong>
                                    Insomniac Games &mdash; 
                                                                          Burbank,
                                                                                                              California,
                                                                        United States
                                    <br />
                                    [04.20.21]
                                   </strong>
                                   <br />
                                   <a href="https://jobs.gamasutra.com/job/narrative-system-designer-burbank-california-34873">Narrative System Designer</a>
                                </div>
                           </div>
                                                   <div class="stories_item">
                                <div class="thumb"><a href="https://jobs.gamasutra.com/job/senior-game-designer-for-a-new-f2p-mobile-game-feature-design-amp-amp-live-ops-hamburg-34913"><img src="https://d1506sp6x4e9z7.cloudfront.net/gamasutra/uploads/1019161.png" alt="innogames" width="120"></a></div>
                                <div class="title">
                                    <strong>
                                    innogames &mdash; 
                                                                          Hamburg,
                                                                                                            Germany
                                    <br />
                                    [04.20.21]
                                   </strong>
                                   <br />
                                   <a href="https://jobs.gamasutra.com/job/senior-game-designer-for-a-new-f2p-mobile-game-feature-design-amp-amp-live-ops-hamburg-34913">Senior Game Designer for a new F2P Mobile Game - Feature Design &amp; Live Ops</a>
                                </div>
                           </div>
                                                   <div class="stories_item">
                                <div class="thumb"><a href="https://jobs.gamasutra.com/job/-experienced-haxe-developer-ndash-video-game-forge-of-empires-ndash-innogames-hamburg-34962"><img src="https://d1506sp6x4e9z7.cloudfront.net/gamasutra/uploads/1019161.png" alt="innogames" width="120"></a></div>
                                <div class="title">
                                    <strong>
                                    innogames &mdash; 
                                                                          Hamburg,
                                                                                                            Germany
                                    <br />
                                    [04.20.21]
                                   </strong>
                                   <br />
                                   <a href="https://jobs.gamasutra.com/job/-experienced-haxe-developer-ndash-video-game-forge-of-empires-ndash-innogames-hamburg-34962">(Experienced) Haxe Developer &ndash; Video Game: Forge of Empires &ndash; InnoGames</a>
                                </div>
                           </div>
                                                   <div class="stories_item">
                                <div class="thumb"><a href="https://jobs.gamasutra.com/job/senior-concept-artist-bellevue-washington-34947"><img src="https://d1506sp6x4e9z7.cloudfront.net/gamasutra/uploads/AU358.gif" alt="Sucker Punch Productions" width="120"></a></div>
                                <div class="title">
                                    <strong>
                                    Sucker Punch Productions &mdash; 
                                                                          Bellevue,
                                                                                                              Washington,
                                                                        United States
                                    <br />
                                    [04.19.21]
                                   </strong>
                                   <br />
                                   <a href="https://jobs.gamasutra.com/job/senior-concept-artist-bellevue-washington-34947">Senior Concept Artist</a>
                                </div>
                           </div>
                                            </div>
                    <br class="clear"/><br/>
                    <div class="right small">
                        <strong>[<a href="https://jobs.gamasutra.com/">View All Jobs</a>]</strong>
                    </div>
                    <br class="clear"/><br/>
                                        <hr>
            							<script type='text/javascript'>
																
								//Rectangle 1 on small mobile device
								if (document.documentElement.clientWidth <= 767)
								{ document.write('<div id="div-gpt-ad-rec1"><center>'); 
										googletag.cmd.push(function(){
											googletag.display('div-gpt-ad-rec1'); 
										});
										document.write('</center></div>'); }
								
							</script>


                <div id="dynamiccomments">
					<span id="cmtArticleId" style="display:none">194321</span>
					<span id="cmtStory_type" style="display:none">blog</span>
					<span id="cmtArticleUri" style="display:none">/blogs/AdamFoster/20130617/194321/?utm_source=feedburner&utm_medium=feed&utm_campaign=Feed%3A+GamasutraFeatureArticles+%28Gamasutra+Feature+Articles%29</span>
					<span id="author_id" style="display:none">939620</span>
					<span id="author_user_id" style="display:none"></span>
                    <a style="font-weight: bold; font-size: 16px;" name="comments"> Loading Comments</a>
                    <br />
                    <hr noshade size="1" class="hr_comment">
                
                    <div align="center">
                         <img style="padding-top: 2px; padding-right: 5px; padding-bottom: 5px;" alt="loader image" src="/ajax-loader.gif"/>
                    </div>
       
                </div>
                    </div>  
        <!-- InstanceEndEditable -->
    </div><!--end contentbox-->
</div><!--end span-16-->

            </div>
            <br class="clear">
	</div><!--end span-21-->

        <!--begin right sidebar-->
     	<div class="hide-phone center">
               <div class="span-4 last">
                   <!--right hand ads start here-->

  
                            <!-- Beginning Sync AdSlot 7 for Ad unit Gamasutra/ ### size: [[160,600]]  -->
<div id='div-gpt-ad-sky1'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-sky1');
	}
	);
 </script>
</div>
<!-- End AdSlot 7 -->
        <!-- Beginning Sync AdSlot 8 for Ad unit Gamasutra/ ### size: [[160,160]]  -->
<div id='div-gpt-ad-Ltile1'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-Ltile1');
	}
	);
 </script>
</div>
<!-- End AdSlot 8 -->
      
		 
               	</div>
                 </div>
     <!--end right sidebar--> 
        <!-- </div> Extra Div -->
					<!-- Beginning Sync AdSlot 21 for Ad unit Gamasutra/ ### size: [[8,2]]  -->
<div id='div-gpt-ad-native'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-native');
	}
	);
 </script>
</div>
<!-- End AdSlot 21 -->
			<!-- Beginning Sync AdSlot 22 for Ad unit Gamasutra/ ### size: [[8,4]]  -->
<div id='div-gpt-ad-insight'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-insight');
	}
	);
 </script>
</div>
<!-- End AdSlot 22 -->
			<!-- Beginning Sync AdSlot 23 for Ad unit Gamasutra/ ### size: [[4,4]]  -->
<div id='div-gpt-ad-video'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-video');
	}
	);
 </script>
</div>
<!-- End AdSlot 23 -->
		

     <br class="clear">
<link rel="stylesheet" type="text/css" href="https://twimgs.com/informationweek/footernav/jan2015/css/superfooter_dark.css" />
<link rel="stylesheet" type="text/css" href="https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css" />
<link rel="stylesheet" type="text/css" href="https://twimgs.com/nojitter/css/common-footer.css?" />
<div align="center">
          <!-- Beginning Sync AdSlot 6 for Ad unit Gamasutra/ ### size: [[3,3]]  -->
<div id='div-gpt-ad-ribbon'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-ribbon');
	}
	);
 </script>
</div>
<!-- End AdSlot 6 -->
</div>

</div><!--end content-body-wrapper-->
     </div><!--end container-->
<!--begin footer-->
<style type="text/css">

@media (min-width: 992px){
	.col-md-5.discover {
		width:47%;
	}
	.divisional-footer .divisional-footer-container .col-md-2 ul{
		padding-right: 28%;
	}
	.col-md-5.brand-name {
		width:27%;
	}
	.col-md-6.logo{
		width: 48%;
		padding: 0.5% 0px;
	}
	.col-md-12 p{
		padding-left:40%;
	}
}

</style>
<footer id="#informa-footer">
        <div class="divisional-footer" style="/*padding-left:10px;padding-right:10px;*/max-width:none;">
            <div class="divisional-footer-container">
                <!--divisional plus marketing -->
                <div class="alternate">
                    <div class="footer-row" style="border-bottom: 1px solid #fff;">
                        <div class="col-md-5 discover">
                            <div class="heading">Discover more from Informa Tech</div>
                            <ul class="list-inline">
                                <li><a href="https://www.gdconf.com" title="Game Developers Conference" target="_blank">Game Developers Conference</a></li>
								<li><a href="https://igf.com/" title="Independent Games Festival" target="_blank">Independent Games Festival</a></li>
								<li><a href="https://jobs.gamasutra.com/" title="Gamasutra Jobs" target="_blank">Gamasutra Jobs</a></li>
								<li><a href="https://www.gamechoiceawards.com/" title="Game Developers Choice Awards" target="_blank">Game Developers Choice Awards</a></li>
								<li><a href="https://www.gdcvault.com/" title="GDC Vault" target="_blank">GDC Vault</a></li>
								<li><a href="https://www.omdia.com/" title="Omdia" target="_blank">Omdia</a></li>
								<li><a href="https://www.gamecareerguide.com/" title="Game Career Guide" target="_blank">Game Career Guide</a></li>
                            </ul>
                        </div>
                        <div class="col-md-2 working">
                            <div class="heading">Working With Us</div>
                            <ul class="list-inline">
								<li>
                                    <a href="https://www.gamasutra.com/contactus">Contact us</a>
                                </li>
                                <li>
                                    <a href="https://www.gamasutra.com/static2/howwework.html">About Us</a>
                                </li>
                                <li>
                                    <a
                                        href="https://www.gamasutra.com/advertise">Advertise</a>
                                </li>
                            </ul>
                        </div>
                        <div class="col-md-5 brand-name">
                            <div class="heading">Follow gamasutra on Social </div>
                            <ul class="list-inline social-icon">
                                <li>
                                    <a href="https://www.facebook.com/pages/Gamasutra/31610613408"><i
                                            class="facebook-white trigger-sc-event"
                                            data-goal-id="715A59A2-A9FC-44E0-B4AF-8A960F2A5116"></i></a>
                                </li>
                                <li>
                                    <a href="https://twitter.com/gamasutra"><i
                                            class="twitter-white trigger-sc-event"
                                            data-goal-id="715A59A2-A9FC-44E0-B4AF-8A960F2A5116"></i></a>
                                </li>
                                <li>
                                    <a href="https://www.gamasutra.com/static2/rssfeeds.html"><i class="rss-feed-white trigger-sc-event"
                                            data-goal-id="715A59A2-A9FC-44E0-B4AF-8A960F2A5116"></i></a>
                                </li>
                            </ul>
                        </div>
                    </div>
                </div>
                <!--DIV-->
            </div>
        </div>

        <div class="divisional-footer">
            <div class="divisional-footer-container">
                <div class="footer-row footer-icons">
                    <div class="col-md-6 logo" style="padding: 0.5% 0px;">
                        <img src="https://twimgs.com/nojitter/img/Whitelogo.png" alt="alt text of the logo">
                    </div>

                    <div class="col-md-6">
                        <ul class="list-inline">
							<li>
                                <a href="https://tech.informa.com/" target="_blank">Home</a>
                            </li>
                            <li>
                                <a href="https://tech.informa.com/cookie-policy" target="_blank">Cookies</a>
                            </li>
							<li>
                                <a href="https://privacyportal-eu-cdn.onetrust.com/dsarwebform/c1f53e84-9f05-4169-a854-85052b63c50b/5f26b553-52cc-4973-a761-295d5634a6b6.html" target="_blank">CCPA: Do not sell my personal info</a>
                            </li>
                            <li>
                                <a href="https://tech.informa.com/privacy-policy" target="_blank">Privacy</a>
                            </li>
                            <li>
                                <a href="https://tech.informa.com/terms-and-conditions" target="_blank">Terms</a>
                            </li>
                        </ul>
                    </div>
                </div>
                <div class="footer-row privacy-policy">
                    <div class="col-md-12">
                        <p class="copyright">Copyright &copy; 2021 Informa PLC
                            Informa UK Limited is a company registered in England and Wales with company number 1072954
                            whose registered office is 5 Howick Place, London, SW1P 1WG.
                        </p>
                    </div>
                </div>
            </div>
        </div>
    </footer>
<!--end footer-->

<script type="text/javascript">
	var registerData='';
	registerCheck();
	function registerCheck(){
		$.ajax({
			url: '/omnloginstatus.php',
			async : false,
			success: function(result){
				registerData = result.replace('"','');
				registerData = registerData.replace('"','');
			}
		});
	}
</script>

<script type="text/javascript" src="https://twimgs.com/nojitter/gama/js/oasTrack_v1.js"></script>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
<script type="text/javascript" src="https://apis.google.com/js/plusone.js"></script>
<!-- SiteCatalyst code version: H.21.
Copyright 1996-2010 Adobe, Inc. All Rights Reserved
More info available at http://www.omniture.com -->

<script language="JavaScript" type="text/javascript" src="https://twimgs.com/custom/library.gtecevent.com/assets/ubm-tech-global-app-measurement.js?ormzkk"></script>
<script language="JavaScript" type="text/javascript"><!--
    /* You may give each page an identifying name, server, and channel on
    the next lines. */
	s.pageName="";
	s.server="";
	s.channel="";
	s.pageType="";
	s.prop1="";
	s.prop2="194321";
	s.prop3="Gamasustra | 194321 | Alternate Reality Game puzzle design";
	s.prop4="Alternate Reality Game puzzle design";
	s.prop5="GAMASUTRA BLOG";
	s.prop6="";
	s.prop7="Adam Foster";
	s.prop8="userAgent";
	s.prop9="";
	s.prop10="";
	s.prop13="";
    s.prop19=registerData;
	s.contextData['Newsletter_signup'] ="";
	/* Conversion Variables */
	s.campaign="";
	s.state="";
	s.zip="";
	s.events="event5";
	s.products="";
	s.purchaseID="";
	s.eVar1="design";
	s.eVar2="";
	s.eVar3="";
	s.eVar4="";
	s.eVar5="";
	/************* DO NOT ALTER ANYTHING BELOW THIS LINE ! **************/
  var s_code = s.t(); if (s_code) document.write(s_code)//--></script>
<script language="JavaScript" type="text/javascript"><!--
    if (navigator.appVersion.indexOf('MSIE') >= 0) document.write(unescape('%3C') + '\!-' + '-')
//--></script><noscript><a href="http://www.omniture.com" title="Web Analytics"><img
src="http://cmp.112.2o7.net/b/ss/cmpglobalvista/1/H.21--NS/0"
height="1" width="1" border="0" alt="" /></a></noscript><!--/DO NOT REMOVE/-->
<!-- End SiteCatalyst code version: H.21. -->

<!-- Begin ADSNATIVE Code -->
<script type="text/javascript" src="https://static.adsnative.com/static/js/render.v1.js"></script>
<!-- End ADSNATIVE Code -->
<!--Begin Ad script for pixel -->

<script type="text/javascript">
    adroll_adv_id = "AJSB6AWABZB2RFHAOYSOZH";
    adroll_pix_id = "2RTKKW6YFBHIVKRM6FNJ4D";
    /* OPTIONAL: provide email to improve user identification */
    /* adroll_email = "username@example.com"; */
    (function () {
        var _onload = function(){
            if (document.readyState && !/loaded|complete/.test(document.readyState)){setTimeout(_onload, 10);return}
            if (!window.__adroll_loaded){__adroll_loaded=true;setTimeout(_onload, 50);return}
            var scr = document.createElement("script");
            var host = (("https:" == document.location.protocol) ? "https://s.adroll.com" : "http://a.adroll.com");
            scr.setAttribute('async', 'true');
            scr.type = "text/javascript";
            scr.src = host + "/j/roundtrip.js";
            ((document.getElementsByTagName('head') || [null])[0] ||
                document.getElementsByTagName('script')[0].parentNode).appendChild(scr);
        };
        if (window.addEventListener) {window.addEventListener('load', _onload, false);}
        else {window.attachEvent('onload', _onload)}
    }());
</script>

<!--END Ad script for pixel -->


<script type="text/javascript">
  var isChrome = /Chrome/.test(navigator.userAgent) && /Google Inc/.test(navigator.vendor);
  if(isChrome) {
    setInterval(function(){
      if(ngcheckLoggedIn()) {
        sessionAlive();
      }
    }, 180000); // 3 mins of interval
    function sessionAlive() {
      $.ajax({
        url: '/sessionAjax.php',
        success: function(){}
      });
    }
  }
</script>

</body>
</html>                
                